NO
Product
Notepad++
On CISA KEVExploited in the wild
5
CVEs
1
On KEV
7.5
Max CVSS
0
New 30D
Severity mix
Critical 0High 1Medium 2Low 0
Watch
Add Notepad++ to your stack to get only the CVEs that touch what you run.
| CVE | CVSS | Published | Summary · affected versions |
|---|---|---|---|
| CVE-2025-15556 In wildKEV | 7.5 | Feb 3 | Notepad++ < 8.8.9 WinGUp Updater Lacks Update Integrity Verification Affected: All versions, or not specified |
| CVE-2026-3008 | 6.6 | Apr 27 | Vulnerability in Notepad++ Affected: 8.9.3 |
| CVE-2026-6539 | 4.4 | Apr 30 | Notepad++ 8.9.3 Format String Injection via nativeLang.xml Affected: before 8.9.4 |
| CVE-2008-3436 | – | Aug 1 | The GUP generic update process in Notepad++ before 4.8.1 does not properly verify the authenticity of updates, which allows man-in-the-middle attackers to execute arbitrary code… Affected: through 1.0; through 1.1; through 1.2; through 1.3; through 1.4; through 1.5; +34 more |
| CVE-2007-2666 | – | May 14 | Stack-based buffer overflow in LexRuby.cxx (SciLexer.dll) in Scintilla 1.73, as used by notepad++ 4.1.1 and earlier, allows user-assisted remote attackers to execute arbitrary… Affected: through 4.1.1 |
Showing 5
