Unscored severity · published May 14, 2007
CVE-2007-2666
Stack-based buffer overflow in LexRuby.cxx (SciLexer.dll) in Scintilla 1.73, as used by notepad++ 4.1.1 and earlier, allows user-assisted remote attackers to execute arbitrary…
–
CVSS
15.5%
EPSS
No
On KEV
Description
Stack-based buffer overflow in LexRuby.cxx (SciLexer.dll) in Scintilla 1.73, as used by notepad++ 4.1.1 and earlier, allows user-assisted remote attackers to execute arbitrary code via certain Ruby (.rb) files with long lines. NOTE: this was originally reported as a vulnerability in notepad++.
Exploitation
Is it being used?
Exploit prediction (EPSS)15.5% · higher than 97% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
NO
Notepad++ · Notepad++
through 4.1.1 · source: NVD
SC
Scintilla · Scintilla
1.73 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2007-2666
CVE.org
https://www.cve.org/CVERecord?id=CVE-2007-2666
osvdb.org
http://osvdb.org/36007
scintilla.cvs.sourceforge.net
http://scintilla.cvs.sourceforge.net/scintilla/scintilla/src/LexRuby.cxx?view=log#rev1.13
Vendor Advisory
http://secunia.com/advisories/25245
secunia.com
http://secunia.com/advisories/25327
www.securityfocus.com
http://www.securityfocus.com/archive/1/468529/100/0/threaded
www.securityfocus.com
http://www.securityfocus.com/archive/1/469348/100/100/threaded
More from Notepad++
7.5
CVE-2025-15556
Notepad++ < 8.8.9 WinGUp Updater Lacks Update Integrity Verification
6.6
CVE-2026-3008
Vulnerability in Notepad++
4.4
CVE-2026-6539
Notepad++ 8.9.3 Format String Injection via nativeLang.xml
–
CVE-2008-3436
The GUP generic update process in Notepad++ before 4.8.1 does not properly verify the authenticity of updates, which allows man-in-the-middle attackers to execute arbitrary code…
