Unscored severity · published Aug 1, 2008
CVE-2008-3436
The GUP generic update process in Notepad++ before 4.8.1 does not properly verify the authenticity of updates, which allows man-in-the-middle attackers to execute arbitrary code…
–
CVSS
1.8%
EPSS
No
On KEV
Description
The GUP generic update process in Notepad++ before 4.8.1 does not properly verify the authenticity of updates, which allows man-in-the-middle attackers to execute arbitrary code via a Trojan horse update, as demonstrated by evilgrade and DNS cache poisoning.
Exploitation
Is it being used?
Exploit prediction (EPSS)1.8% · higher than 79% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
NO
Notepad++ · Notepad++
through 1.0; through 1.1; through 1.2; through 1.3; through 1.4; through 1.5; +34 more · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2008-3436
CVE.org
https://www.cve.org/CVERecord?id=CVE-2008-3436
archives.neohapsis.com
http://archives.neohapsis.com/archives/bugtraq/2008-07/0250.html
www.infobyte.com.ar
http://www.infobyte.com.ar/down/Francisco%20Amato%20-%20evilgrade%20-%20ENG.pdf
www.infobyte.com.ar
http://www.infobyte.com.ar/down/isr-evilgrade-1.0.0.tar.gz
More from Notepad++
7.5
CVE-2025-15556
Notepad++ < 8.8.9 WinGUp Updater Lacks Update Integrity Verification
6.6
CVE-2026-3008
Vulnerability in Notepad++
4.4
CVE-2026-6539
Notepad++ 8.9.3 Format String Injection via nativeLang.xml
–
CVE-2007-2666
Stack-based buffer overflow in LexRuby.cxx (SciLexer.dll) in Scintilla 1.73, as used by notepad++ 4.1.1 and earlier, allows user-assisted remote attackers to execute arbitrary…
