Medium severity · published Apr 27, 2026
CVE-2026-3008
Vulnerability in Notepad++
6.6
CVSS
0.2%
EPSS
No
On KEV
Description
Successful exploitation of the
string injection vulnerability could allow an attacker to obtain memory address
information or crash the application.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H
Attack vector
Local
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 13% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
NO
Notepad++ · Notepad++
8.9.3 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-3008
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-3008
community.notepad-plus-plus.org
https://community.notepad-plus-plus.org/topic/27500/notepad-v8-9-4-release-candidate
github.com
https://github.com/llgsjsm/cve-2026-3008
github.com
https://github.com/notepad-plus-plus/notepad-plus-plus/issues/17960
llgsjsm.github.io
https://llgsjsm.github.io/cve-2026-3008/
www.csa.gov.sg
https://www.csa.gov.sg/alerts-and-advisories/alerts/al-2026-044/
More from Notepad++
7.5
CVE-2025-15556
Notepad++ < 8.8.9 WinGUp Updater Lacks Update Integrity Verification
4.4
CVE-2026-6539
Notepad++ 8.9.3 Format String Injection via nativeLang.xml
–
CVE-2008-3436
The GUP generic update process in Notepad++ before 4.8.1 does not properly verify the authenticity of updates, which allows man-in-the-middle attackers to execute arbitrary code…
–
CVE-2007-2666
Stack-based buffer overflow in LexRuby.cxx (SciLexer.dll) in Scintilla 1.73, as used by notepad++ 4.1.1 and earlier, allows user-assisted remote attackers to execute arbitrary…
