EX
Product
exim
On CISA KEVExploited in the wildRansomware-linked
70
CVEs
5
On KEV
9.8
Max CVSS
0
New 30D
Severity mix
Critical 23High 26Medium 12Low 1
Watch
Add exim to your stack to get only the CVEs that touch what you run.
| CVE | CVSS | Published | Summary · affected versions |
|---|---|---|---|
| CVE-2019-16928 In wildKEV | 9.8 | Sep 27 | Exim Out-of-bounds Write Vulnerability Affected: 4.92 through 4.92.2 |
| CVE-2019-10149 In wildKEV | 9.8 | Jun 5 | Exim Mail Transfer Agent (MTA) Improper Input Validation Affected: 4.92 |
| CVE-2018-6789 RansomwareIn wildKEV | 9.8 | Feb 8 | Exim Buffer Overflow Vulnerability Affected: before 4.90.1 |
| CVE-2010-4344 In wildKEV | 9.8 | Dec 14 | Exim Heap-Based Buffer Overflow Vulnerability Affected: before 4.70 |
| CVE-2026-45185 | 9.8 | May 12 | Exim before 4.99.3, in certain GnuTLS configurations, has a remotely reachable use-after-free in the BDAT body parsing path Affected: 4.97 before 4.99.3 |
| CVE-2026-40685 | 9.8 | Apr 30 | In Exim before 4.99.2, when JSON lookup is enabled, an out-of-bounds heap write can occur when a JSON operator encounters malformed JSON in an untrusted header, because of an… Affected: before 4.99.2 |
| CVE-2025-67896 | 9.8 | Dec 14 | Exim before 4.99.1, with certain non-default rate-limit configurations, allows a remote heap-based buffer overflow because database records are cast directly to internal… Affected: before 4.99.1 |
| CVE-2025-26794 | 9.8 | Feb 21 | Exim 4.98 before 4.98.1, when SQLite hints and ETRN serialization are used, allows remote SQL injection Affected: 4.98 before 4.98.1 |
| CVE-2023-42117 | 9.8 | May 3 | Exim Improper Neutralization of Special Elements Remote Code Execution Vulnerability Affected: before 4.96.2 |
| CVE-2023-42116 | 9.8 | May 3 | Exim SMTP Challenge Stack-based Buffer Overflow Remote Code Execution Vulnerability Affected: before 4.96.1 |
| CVE-2023-42115 | 9.8 | May 3 | Exim AUTH Out-Of-Bounds Write Remote Code Execution Vulnerability Affected: before 4.96.1 |
| CVE-2022-3620 | 9.8 | Oct 20 | Exim DMARC dmarc.c dmarc_dns_lookup use after free Affected: 4.95 before 4.97 |
| CVE-2022-37452 | 9.8 | Aug 7 | Exim before 4.95 has a heap-based buffer overflow for the alias list in host_name_lookup in host.c when sender_host_name is set Affected: before 4.95 |
| CVE-2020-28026 | 9.8 | May 6 | Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters, relevant in non-default configurations that enable Delivery Status Notification (DSN) Affected: 4.00 before 4.94.2 |
| CVE-2020-28024 | 9.8 | May 6 | Exim 4 before 4.94.2 allows Buffer Underwrite that may result in unauthenticated remote attackers executing arbitrary commands, because smtp_ungetc was only intended to push back… Affected: 4.00 before 4.94.2 |
| CVE-2020-28022 | 9.8 | May 6 | Exim 4 before 4.94.2 has Improper Restriction of Write Operations within the Bounds of a Memory Buffer Affected: 4.00 before 4.94.2 |
| CVE-2020-28020 | 9.8 | May 6 | Exim 4 before 4.92 allows Integer Overflow to Buffer Overflow, in which an unauthenticated remote attacker can execute arbitrary code by leveraging the mishandling of continuation… Affected: 4.00 before 4.92 |
| CVE-2020-28018 | 9.8 | May 6 | Exim 4 before 4.94.2 allows Use After Free in smtp_reset in certain situations that may be common for builds with OpenSSL Affected: 4.90 before 4.94.2 |
| CVE-2020-28017 | 9.8 | May 6 | Exim 4 before 4.94.2 allows Integer Overflow to Buffer Overflow in receive_add_recipient via an e-mail message with fifty million recipients Affected: before 4.94.1 |
| CVE-2019-15846 | 9.8 | Sep 6 | Exim before 4.92.2 allows remote attackers to execute arbitrary code as root via a trailing backslash Affected: before 4.92.2 |
| CVE-2019-13917 | 9.8 | Jul 25 | Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an… Affected: 4.85 through 4.92 |
| CVE-2017-16943 | 9.8 | Nov 25 | The receive_msg function in receive.c in the SMTP daemon in Exim 4.88 and 4.89 allows remote attackers to execute arbitrary code or cause a denial of service (use-after-free) via… Affected: 4.88; 4.89 |
| CVE-2026-40687 | 9.1 | Apr 30 | In Exim before 4.99.2, when the SPA authentication driver is used with an adversarial SPA resource, there can be an out-of-bounds write that crashes the connection instance, or… Affected: before 4.99.2 |
Showing 23
