Critical severity · published Jul 25, 2019
CVE-2019-13917
Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an…
9.8
CVSS
8.6%
EPSS
No
On KEV
Description
Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an attacker (e.g., $local_part or $domain).
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)8.6% · higher than 95% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
9.0; 10.0 · source: NVD
EX
Exim · Exim
4.85 through 4.92 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2019-13917
CVE.org
https://www.cve.org/CVERecord?id=CVE-2019-13917
Patch
http://exim.org/static/doc/security/CVE-2019-13917.txt
Third Party Advisory
http://www.openwall.com/lists/oss-security/2019/07/26/5
Third Party Advisory
https://seclists.org/bugtraq/2019/Jul/51
security.gentoo.org
https://security.gentoo.org/glsa/201909-06
Third Party Advisory
https://www.debian.org/security/2019/dsa-4488
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
