Medium severity · published Oct 1, 2026
CVE-2026-94276
Apache APISIX: Openid-connect introspection validation issue
5.1
CVSS
0.3%
EPSS
No
On KEV
Description
Improper Authentication vulnerability in Apache APISIX.
On a route using openid-connect plugin with remote introspection against an authorization server that serves multiple issuers, a token that introspects as active for one issuer may get accepted on a route restricted to another. This issue affects Apache APISIX: from 3.12.0 through 3.18.0.
Users are recommended to upgrade to version 3.19.0, which fixes the issue.
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 27% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AA
Apache APISIX · Apache Software Foundation
3.12.0 through 3.18.0 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-94276
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-94276
vendor-advisory
https://lists.apache.org/thread.html/txn3br25kl657fh15rwcy1oht1xbpyyk
More from Apache APISIX
9.8
CVE-2022-24112
apisix/batch-requests plugin allows overwriting the X-REAL-IP header
9.3
CVE-2026-49871
Apache APISIX: cas-auth login CSRF / session injection issue
9.1
CVE-2026-49230
Apache APISIX: Authentication bypass in jwe-decrypt
9.1
CVE-2026-44087
Apache APISIX: Openid-connect plugin Identity Header Spoofing
9.1
CVE-2026-39999
Apache APISIX: JWT Algorithm Confusion allows authentication bypass
