Critical severity · published Jun 19, 2026
CVE-2026-49871
Apache APISIX: cas-auth login CSRF / session injection issue
9.3
CVSS
0.4%
EPSS
No
On KEV
Description
Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations.
This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity.
Actions the victim takes upstream are then attributed to attackers identity.
This issue affects Apache APISIX: from 3.0.0 through 3.16.0.
Users are recommended to upgrade to version 3.17.0, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
High
Integrity
High
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 29% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AA
Apache APISIX · Apache Software Foundation
3.0.0 through 3.16.0 · source: vendor
AP
Apisix · Apache
3.0.0 before 3.17.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-49871
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-49871
Vendor Advisory
https://lists.apache.org/thread/1ozsnss0lof4gpwq763d66oxwxt3sycp
Third Party Advisory
http://www.openwall.com/lists/oss-security/2026/06/19/14
More from Apache APISIX
9.8
CVE-2022-24112
apisix/batch-requests plugin allows overwriting the X-REAL-IP header
9.1
CVE-2026-49230
Apache APISIX: Authentication bypass in jwe-decrypt
9.1
CVE-2026-44087
Apache APISIX: Openid-connect plugin Identity Header Spoofing
9.1
CVE-2026-39999
Apache APISIX: JWT Algorithm Confusion allows authentication bypass
9.1
CVE-2026-31908
Apache APISIX: forward auth plugin allows header injection
