Critical severity · published Jun 19, 2026
CVE-2026-39999
Apache APISIX: JWT Algorithm Confusion allows authentication bypass
9.1
CVSS
0.6%
EPSS
No
On KEV
Description
Authentication Bypass by Spoofing vulnerability in Apache APISIX.
The attacker can completely bypass authentication capitalising on certain configurations of jwt-auth plugin.
This issue affects Apache APISIX: from v2.2 through v3.16.0.
Users are recommended to upgrade to version v3.17.0, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 50% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AA
Apache APISIX · Apache Software Foundation
2.2 through 3.16.0 · source: vendor
AP
Apisix · Apache
2.2 before 3.17.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-39999
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-39999
Vendor Advisory
https://lists.apache.org/thread/nfopt8cnxd3k0rs1oxtr7lzxrdw4mojq
Third Party Advisory
http://www.openwall.com/lists/oss-security/2026/06/19/5
More from Apache APISIX
9.8
CVE-2022-24112
apisix/batch-requests plugin allows overwriting the X-REAL-IP header
9.3
CVE-2026-49871
Apache APISIX: cas-auth login CSRF / session injection issue
9.1
CVE-2026-49230
Apache APISIX: Authentication bypass in jwe-decrypt
9.1
CVE-2026-44087
Apache APISIX: Openid-connect plugin Identity Header Spoofing
9.1
CVE-2026-31908
Apache APISIX: forward auth plugin allows header injection
