Critical severity · published Jun 19, 2026
CVE-2026-44087
Apache APISIX: Openid-connect plugin Identity Header Spoofing
9.1
CVSS
0.3%
EPSS
No
On KEV
Description
Insufficient Verification of Data Authenticity vulnerability in Apache APISIX.
The openid-connect plugin under default configuration has an attack surface that allows the attacker to spoof identity headers allowing the attacker to get unauthorized access the protected resources.
This issue affects Apache APISIX: from 2.3 through 3.16.0.
Users are recommended to upgrade to version 3.17.0, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 21% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AA
Apache APISIX · Apache Software Foundation
2.3 through 3.16.0 · source: vendor
AP
Apisix · Apache
2.3 before 3.17.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-44087
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-44087
Vendor Advisory
https://lists.apache.org/thread/72ryrgdssk6s2x9d6xn14bxyyl878xfm
Third Party Advisory
http://www.openwall.com/lists/oss-security/2026/06/19/7
More from Apache APISIX
9.8
CVE-2022-24112
apisix/batch-requests plugin allows overwriting the X-REAL-IP header
9.3
CVE-2026-49871
Apache APISIX: cas-auth login CSRF / session injection issue
9.1
CVE-2026-49230
Apache APISIX: Authentication bypass in jwe-decrypt
9.1
CVE-2026-39999
Apache APISIX: JWT Algorithm Confusion allows authentication bypass
9.1
CVE-2026-31908
Apache APISIX: forward auth plugin allows header injection
