Medium severity · published Oct 1, 2026
CVE-2026-94212
Apache APISIX: unauthenticated impersonation issue in saml-auth
6.4
CVSS
0.2%
EPSS
No
On KEV
Description
Improper verification of cryptographic signature vulnerability in Apache APISIX. Any unauthenticated attacker could impersonate any user on every route protected by the saml-auth plugin under default configuration. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 11% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AA
Apache APISIX · Apache Software Foundation
3.17.0 through 3.18.0 · source: vendor
Affected product
AA
Apache APISIX
Apache Software Foundation
More from Apache APISIX
9.8
CVE-2022-24112
apisix/batch-requests plugin allows overwriting the X-REAL-IP header
9.3
CVE-2026-49871
Apache APISIX: cas-auth login CSRF / session injection issue
9.1
CVE-2026-49230
Apache APISIX: Authentication bypass in jwe-decrypt
9.1
CVE-2026-44087
Apache APISIX: Openid-connect plugin Identity Header Spoofing
9.1
CVE-2026-39999
Apache APISIX: JWT Algorithm Confusion allows authentication bypass