High severity · published Apr 14, 2026
CVE-2026-31923
Apache APISIX: Openid-connect `tls_verify` field is disabled by default
7.5
CVSS
0.2%
EPSS
No
On KEV
Description
Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. This can occur due to `ssl_verify` in openid-connect plugin configuration being set to false by default. This issue affects Apache APISIX: from 0.7 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 16% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AA
Apache APISIX · Apache Software Foundation
0.7 through 3.15.0 · source: vendor
AP
Apisix · Apache
0.7 before 3.16.0 · source: NVD
Affected product
AA
Apache APISIX
Apache Software Foundation
More from Apache APISIX
9.8
CVE-2022-24112
apisix/batch-requests plugin allows overwriting the X-REAL-IP header
9.3
CVE-2026-49871
Apache APISIX: cas-auth login CSRF / session injection issue
9.1
CVE-2026-49230
Apache APISIX: Authentication bypass in jwe-decrypt
9.1
CVE-2026-44087
Apache APISIX: Openid-connect plugin Identity Header Spoofing
9.1
CVE-2026-39999
Apache APISIX: JWT Algorithm Confusion allows authentication bypass