Medium severity · published Apr 3, 2026
CVE-2026-27124
FastMCP: Missing Consent Verification in OAuth Proxy Callback Facilitates Confused Deputy Vulnerabilities
6.1
CVSS
0.2%
EPSS
No
On KEV
Description
FastMCP is the standard framework for building MCP applications. Prior to version 3.2.0, while testing the GitHubProvider OAuth integration, which allows authentication to a FastMCP MCP server via a FastMCP OAuthProxy using GitHub OAuth, it was discovered that the FastMCP OAuthProxy does not properly validate the user's consent upon receiving the authorization code from GitHub. In combination with GitHub’s behavior of skipping the consent page for previously authorized clients, this introduces a Confused Deputy vulnerability. This issue has been patched in version 3.2.0.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 11% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FA
fastmcp · jlowin
< 3.2.0 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-27124
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-27124
Exploit
https://github.com/PrefectHQ/fastmcp/security/advisories/GHSA-rww4-4w9c-7733
More from fastmcp
10.0
CVE-2026-32871
FastMCP OpenAPI Provider has an SSRF & Path Traversal Vulnerability
7.8
CVE-2025-64340
FastMCP has a Command Injection vulnerability - Gemini CLI
7.8
CVE-2025-62801
FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name
6.5
CVE-2025-69196
FastMCP OAuth Proxy token reuse across MCP servers
6.1
CVE-2025-62800
FastMCP vulnerable to reflected XSS in client's callback page
