High severity · published Apr 3, 2026
CVE-2025-64340
FastMCP has a Command Injection vulnerability - Gemini CLI
7.8
CVSS
0.7%
EPSS
No
On KEV
Description
FastMCP is the standard framework for building MCP applications. Prior to version 3.2.0, server names containing shell metacharacters (e.g., &) can cause command injection on Windows when passed to fastmcp install claude-code or fastmcp install gemini-cli. These install paths use subprocess.run() with a list argument, but on Windows the target CLIs often resolve to .cmd wrappers that are executed through cmd.exe, which interprets metacharacters in the flattened command string. This issue has been patched in version 3.2.0.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack vector
Local
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.7% · higher than 54% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FA
fastmcp · jlowin
< 3.2.0 · source: vendor, NVD
Affected product
FA
fastmcp
jlowin
More from fastmcp
10.0
CVE-2026-32871
FastMCP OpenAPI Provider has an SSRF & Path Traversal Vulnerability
7.8
CVE-2025-62801
FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name
6.5
CVE-2025-69196
FastMCP OAuth Proxy token reuse across MCP servers
6.1
CVE-2026-27124
FastMCP: Missing Consent Verification in OAuth Proxy Callback Facilitates Confused Deputy Vulnerabilities
6.1
CVE-2025-62800
FastMCP vulnerable to reflected XSS in client's callback page