Medium severity · published Oct 28, 2025
CVE-2025-62800
FastMCP vulnerable to reflected XSS in client's callback page
6.1
CVSS
0.3%
EPSS
No
On KEV
Description
FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0 have a reflected cross-site scripting vulnerability in the OAuth client callback page (oauth_callback.py) where unescaped user-controlled values are inserted into the generated HTML, allowing arbitrary JavaScript execution in the callback server origin. The issue is fixed in version 2.13.0.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 20% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FA
fastmcp · jlowin
< 2.13.0 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-62800
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-62800
Exploit
https://github.com/jlowin/fastmcp/security/advisories/GHSA-mxxr-jv3v-6pgc
More from fastmcp
10.0
CVE-2026-32871
FastMCP OpenAPI Provider has an SSRF & Path Traversal Vulnerability
7.8
CVE-2025-64340
FastMCP has a Command Injection vulnerability - Gemini CLI
7.8
CVE-2025-62801
FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name
6.5
CVE-2025-69196
FastMCP OAuth Proxy token reuse across MCP servers
6.1
CVE-2026-27124
FastMCP: Missing Consent Verification in OAuth Proxy Callback Facilitates Confused Deputy Vulnerabilities
