High severity · published Oct 28, 2025
CVE-2025-62801
FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name
7.8
CVSS
0.2%
EPSS
No
On KEV
Description
FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0, a command-injection vulnerability lets any attacker who can influence the server_name field of an MCP execute arbitrary OS commands on Windows hosts that run fastmcp install cursor. This vulnerability is fixed in 2.13.0.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Local
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 13% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FA
fastmcp · jlowin
< 2.13.0 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2025-62801
CVE.org
https://www.cve.org/CVERecord?id=CVE-2025-62801
Exploit
https://github.com/jlowin/fastmcp/security/advisories/GHSA-rj5c-58rq-j5g5
More from fastmcp
10.0
CVE-2026-32871
FastMCP OpenAPI Provider has an SSRF & Path Traversal Vulnerability
7.8
CVE-2025-64340
FastMCP has a Command Injection vulnerability - Gemini CLI
6.5
CVE-2025-69196
FastMCP OAuth Proxy token reuse across MCP servers
6.1
CVE-2026-27124
FastMCP: Missing Consent Verification in OAuth Proxy Callback Facilitates Confused Deputy Vulnerabilities
6.1
CVE-2025-62800
FastMCP vulnerable to reflected XSS in client's callback page
