Medium severity · published Jun 24, 2024
CVE-2024-27136
XSS in Upload page in Apache JSPWiki 2.12.1 and priors allows the attacker to execute javascript in the victim's browser and get some sensitive information about the victim
6.1
CVSS
60.8%
EPSS
No
On KEV
Description
XSS in Upload page in Apache JSPWiki 2.12.1 and priors allows the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.2 or later.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)60.8% · higher than 99% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
JS
Jspwiki · Apache
before 2.12.2 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2024-27136
CVE.org
https://www.cve.org/CVERecord?id=CVE-2024-27136
Vendor Advisory
https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2024-27136
Vendor Advisory
https://lists.apache.org/thread/gfms8gbncqqkj52p861b8fnsypwsl1d5
www.openwall.com
http://www.openwall.com/lists/oss-security/2024/06/23/3
More from Jspwiki
9.8
CVE-2026-28812
Apache JSPWiki: UserManager does not sanity-check user database at startup
9.1
CVE-2021-44140
Remote attackers may delete arbitrary files in a system hosting a JSPWiki instance, versions up to 2.11.0.M8, by using a carefuly crafted http request on logout, given that those…
8.8
CVE-2026-28813
Apache JSPWiki: JSPWiki vulnerable to JSON hijacking
8.8
CVE-2022-34158
User Group Privilege Escalation
8.8
CVE-2022-24947
Apache JSPWiki user preferences form is vulnerable to CSRF attacks, which can lead to account takeover
