High severity · published Jul 30, 2026
CVE-2026-28813
Apache JSPWiki: JSPWiki vulnerable to JSON hijacking
8.8
CVSS
0.3%
EPSS
No
On KEV
Description
Apache JSPWiki, up to 2.12.3, is vulnerable to JSON Hijacking, which leads to csrf vulnerabilities. Users are recommended to upgrade to version 2.12.4, which fixes this issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 19% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AJ
Apache JSPWiki · Apache Software Foundation
before 2.12.4 · source: vendor
JS
Jspwiki · Apache
before 2.12.4 · source: NVD
Affected product
AJ
Apache JSPWiki
Apache Software Foundation
More from Apache JSPWiki
9.8
CVE-2026-28812
Apache JSPWiki: UserManager does not sanity-check user database at startup
8.8
CVE-2022-34158
User Group Privilege Escalation
7.5
CVE-2026-28814
Apache JSPWiki: Pre-Authentication Arbitrary Wiki Markup Rendering
7.5
CVE-2026-28811
Apache JSPWiki: Error Handling - Reveals Error Details
6.5
CVE-2026-48910
Apache JSPWiki: Markdown parser allows XSS injection in Markdown error processing