High severity · published Feb 25, 2022
CVE-2022-24947
Apache JSPWiki user preferences form is vulnerable to CSRF attacks, which can lead to account takeover
8.8
CVSS
1.2%
EPSS
No
On KEV
Description
Apache JSPWiki user preferences form is vulnerable to CSRF attacks, which can lead to account takeover. Apache JSPWiki users should upgrade to 2.11.2 or later.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.2% · higher than 67% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
JS
Jspwiki · Apache
before 2.11.2 · source: NVD
Affected product
JS
Jspwiki
Apache
More from Jspwiki
9.8
CVE-2026-28812
Apache JSPWiki: UserManager does not sanity-check user database at startup
9.1
CVE-2021-44140
Remote attackers may delete arbitrary files in a system hosting a JSPWiki instance, versions up to 2.11.0.M8, by using a carefuly crafted http request on logout, given that those…
8.8
CVE-2026-28813
Apache JSPWiki: JSPWiki vulnerable to JSON hijacking
8.8
CVE-2022-34158
User Group Privilege Escalation
7.5
CVE-2026-28814
Apache JSPWiki: Pre-Authentication Arbitrary Wiki Markup Rendering