Critical severity · published Nov 24, 2021
CVE-2021-44140
Remote attackers may delete arbitrary files in a system hosting a JSPWiki instance, versions up to 2.11.0.M8, by using a carefuly crafted http request on logout, given that those…
9.1
CVSS
6.4%
EPSS
No
On KEV
Description
Remote attackers may delete arbitrary files in a system hosting a JSPWiki instance, versions up to 2.11.0.M8, by using a carefuly crafted http request on logout, given that those files are reachable to the user running the JSPWiki instance. Apache JSPWiki users should upgrade to 2.11.0 or later.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)6.4% · higher than 94% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
JS
Jspwiki · Apache
before 2.11.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-44140
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-44140
Vendor Advisory
https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2021-44140
Mailing List
https://lists.apache.org/thread/5qglpjdhvobppx7j550lf1sk28f6011t
More from Jspwiki
9.8
CVE-2026-28812
Apache JSPWiki: UserManager does not sanity-check user database at startup
8.8
CVE-2026-28813
Apache JSPWiki: JSPWiki vulnerable to JSON hijacking
8.8
CVE-2022-34158
User Group Privilege Escalation
8.8
CVE-2022-24947
Apache JSPWiki user preferences form is vulnerable to CSRF attacks, which can lead to account takeover
7.5
CVE-2026-28814
Apache JSPWiki: Pre-Authentication Arbitrary Wiki Markup Rendering
