Medium severity · published Aug 4, 2022
CVE-2022-28730
Apache JSPWiki Cross-site scripting vulnerability on AJAXPreview.jsp
6.1
CVSS
86.2%
EPSS
No
On KEV
Description
A carefully crafted request on AJAXPreview.jsp could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This vulnerability leverages CVE-2021-40369, where the Denounce plugin dangerously renders user-supplied URLs. Upon re-testing CVE-2021-40369, it appears that the patch was incomplete as it was still possible to insert malicious input via the Denounce plugin. Apache JSPWiki users should upgrade to 2.11.3 or later.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)86.2% · higher than 100% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AJ
Apache JSPWiki · Apache Software Foundation
Apache JSPWiki through Apache JSPWiki up to 2.11.2 · source: vendor
JS
Jspwiki · Apache
before 2.11.3 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-28730
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-28730
Vendor Advisory
https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-28732
More from Apache JSPWiki
9.8
CVE-2026-28812
Apache JSPWiki: UserManager does not sanity-check user database at startup
8.8
CVE-2026-28813
Apache JSPWiki: JSPWiki vulnerable to JSON hijacking
8.8
CVE-2022-34158
User Group Privilege Escalation
7.5
CVE-2026-28814
Apache JSPWiki: Pre-Authentication Arbitrary Wiki Markup Rendering
7.5
CVE-2026-28811
Apache JSPWiki: Error Handling - Reveals Error Details
