High severity · published Jul 30, 2026
CVE-2026-28811
Apache JSPWiki: Error Handling - Reveals Error Details
7.5
CVSS
0.8%
EPSS
No
On KEV
Description
Debug Messages Revealing Unnecessary Information in Apache JSPWiki up to 2.12.3.
Users are recommended to upgrade to version 2.12.4, which fixes this issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.8% · higher than 56% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AJ
Apache JSPWiki · Apache Software Foundation
before up to 3.0.0 · source: vendor
JS
Jspwiki · Apache
before 2.12.4 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-28811
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-28811
Vendor Advisory
https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2026-28811
Mailing List
https://lists.apache.org/thread/2dm414zzjo3pvhjz6mvqy3b5yhvnkcg5
Mailing List
http://www.openwall.com/lists/oss-security/2026/07/30/14
More from Apache JSPWiki
9.8
CVE-2026-28812
Apache JSPWiki: UserManager does not sanity-check user database at startup
8.8
CVE-2026-28813
Apache JSPWiki: JSPWiki vulnerable to JSON hijacking
8.8
CVE-2022-34158
User Group Privilege Escalation
7.5
CVE-2026-28814
Apache JSPWiki: Pre-Authentication Arbitrary Wiki Markup Rendering
6.5
CVE-2026-48910
Apache JSPWiki: Markdown parser allows XSS injection in Markdown error processing
