High severity · published Jul 30, 2026
CVE-2026-28814
Apache JSPWiki: Pre-Authentication Arbitrary Wiki Markup Rendering
7.5
CVSS
0.7%
EPSS
No
On KEV
Description
Arbitrary Wiki Markup rendering due to lack of authentication in Apache JSPWiki up to 2.12.3 allows attacker to obtain sensitive data stored in JSPWiki variables.
Users are recommended to upgrade to version 2.12.4 or 3.0.0, which fixes this issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.7% · higher than 51% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AJ
Apache JSPWiki · Apache Software Foundation
before 2.12.4 · source: vendor
JS
Jspwiki · Apache
before 2.12.4 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-28814
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-28814
Mailing List
https://lists.apache.org/thread/8vv0311bvrrqxsyn913pcwf7pctyk52w
Mailing List
http://www.openwall.com/lists/oss-security/2026/07/30/17
More from Apache JSPWiki
9.8
CVE-2026-28812
Apache JSPWiki: UserManager does not sanity-check user database at startup
8.8
CVE-2026-28813
Apache JSPWiki: JSPWiki vulnerable to JSON hijacking
8.8
CVE-2022-34158
User Group Privilege Escalation
7.5
CVE-2026-28811
Apache JSPWiki: Error Handling - Reveals Error Details
6.5
CVE-2026-48910
Apache JSPWiki: Markdown parser allows XSS injection in Markdown error processing
