SP
Product
Spice
15
CVEs
0
On KEV
9.8
Max CVSS
0
New 30D
Severity mix
Critical 1High 9Medium 2Low 0
Watch
Add Spice to your stack to get only the CVEs that touch what you run.
| CVE | CVSS | Published | Summary · affected versions |
|---|---|---|---|
| CVE-2016-0749 | 9.8 | Jun 9 | The smartcard interaction in SPICE allows remote attackers to cause a denial of service (QEMU-KVM process crash) or possibly execute arbitrary code via vectors related to… Affected: All versions, or not specified |
| CVE-2018-10893 | 8.8 | Sep 11 | Multiple integer overflow and buffer overflow issues were discovered in spice-client's handling of LZ compressed frames Affected: All versions, or not specified |
| CVE-2018-10873 | 8.8 | Aug 17 | A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks Affected: before 0.14.1 |
| CVE-2016-9577 | 8.8 | Jul 27 | A vulnerability was discovered in SPICE before 0.13.90 in the server's protocol handling Affected: before 0.13.90 |
| CVE-2017-7506 | 8.8 | Jul 18 | spice versions though 0.13 are vulnerable to out-of-bounds memory access when processing specially crafted messages from authenticated attacker to the spice server resulting into… Affected: 0.5.2; 0.5.3; 0.6.0; 0.6.1; 0.6.2; 0.6.3; +24 more |
| CVE-2015-5260 | 7.8 | Jun 7 | Heap-based buffer overflow in SPICE before 0.12.6 allows guest OS users to cause a denial of service (heap-based memory corruption and QEMU-KVM crash) or possibly execute… Affected: through 0.12.5 |
| CVE-2019-3813 | 7.5 | Feb 4 | Spice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of-bounds read due to an off-by-one error in memslot_get_virt Affected: 0.5.2 through 0.14.1 |
| CVE-2016-9578 | 7.5 | Jul 27 | A vulnerability was discovered in SPICE before 0.13.90 in the server's protocol handling Affected: before 0.13.90 |
| CVE-2016-2150 | 7.1 | Jun 9 | SPICE allows local guest OS users to read from or write to arbitrary host memory locations via crafted primary surface parameters, a similar issue to CVE-2015-5261 Affected: All versions, or not specified |
| CVE-2015-5261 | 7.1 | Jun 7 | Heap-based buffer overflow in SPICE before 0.12.6 allows guest OS users to read and write to arbitrary memory locations on the host via guest QXL commands related to surface… Affected: through 0.12.5 |
| CVE-2020-14355 | 6.6 | Oct 7 | Multiple buffer overflow vulnerabilities were found in the QUIC image decoding process of the SPICE remote display system, before spice-0.14.2-1 Affected: before 0.14.2 |
| CVE-2021-20201 | 5.3 | May 28 | A flaw was found in spice in versions before 0.14.92 Affected: before 0.14.92 |
| CVE-2015-3247 | – | Sep 8 | Race condition in the worker_update_monitors_config function in SPICE 0.12.4 allows a remote authenticated guest user to cause a denial of service (heap-based memory corruption… Affected: 0.12.4 |
| CVE-2013-4282 | – | Nov 2 | Stack-based buffer overflow in the reds_handle_ticket function in server/reds.c in SPICE 0.12.0 allows remote attackers to cause a denial of service (crash) via a long password in… Affected: 0.12.0 |
| CVE-2013-4130 | – | Aug 20 | The (1) red_channel_pipes_add_type and (2) red_channel_pipes_add_empty_msg functions in server/red_channel.c in SPICE before 0.12.4 do not properly perform ring loops, which might… Affected: through 0.12.3; 0.5.2; 0.5.3; 0.6.0; 0.6.1; 0.6.2; +18 more |
Showing 15
