AU
Product
Authoritative
32
CVEs
0
On KEV
9.8
Max CVSS
0
New 30D
Severity mix
Critical 2High 17Medium 10Low 0
Watch
Add Authoritative to your stack to get only the CVEs that touch what you run.
| CVE | CVSS | Published | Summary · affected versions |
|---|---|---|---|
| CVE-2026-42000 | 8.6 | May 21 | Insufficient Validation of Names During AXFR Affected: 4.9.0 before 4.9.15; 5.0.0 before 5.0.5 |
| CVE-2020-24696 | 8.1 | Oct 2 | An issue was discovered in PowerDNS Authoritative through 4.3.0 when --enable-experimental-gss-tsig is used Affected: through 4.3.0 |
| CVE-2026-42002 | 7.5 | May 21 | Concurrency and locking defects in GSS-TSIG Affected: 4.9.0 before 4.9.15; 5.0.0 before 5.0.5 |
| CVE-2026-42001 | 7.5 | May 21 | Insufficient Validation of Autoprimary SOA Queries Affected: 4.9.0 before 4.9.15; 5.0.0 before 5.0.5 |
| CVE-2026-33610 | 7.5 | Apr 22 | Possible file descriptor exhaustion in forward-dnsupdate Affected: 5.0.0 before 5.0.4; 4.9.0 before 4.9.14 |
| CVE-2026-33260 | 7.5 | Apr 22 | Insufficient input validation of internal webserver Affected: 5.0.0 before 5.0.4; 4.9.0 before 4.9.14 |
| CVE-2026-33257 | 7.5 | Apr 22 | Insufficient input validation of internal webserver Affected: 5.0.0 before 5.0.4; 4.9.0 before 4.9.14 |
| CVE-2020-24697 | 7.5 | Oct 2 | An issue was discovered in PowerDNS Authoritative through 4.3.0 when --enable-experimental-gss-tsig is used Affected: through 4.3.0 |
| CVE-2015-5230 | 7.5 | Jan 15 | The DNS packet parsing/generation code in PowerDNS (aka pdns) Authoritative Server 3.4.x before 3.4.6 allows remote attackers to cause a denial of service (crash) via crafted… Affected: 3.4.0 before 3.4.6 |
| CVE-2019-10162 | 7.5 | Jul 30 | A vulnerability has been found in PowerDNS Authoritative Server before versions 4.1.10, 4.0.8 allowing an authorized user to cause the server to exit by inserting a crafted record… Affected: 4.0.0 before 4.0.8; 4.1.0 before 4.1.10; 4.0.0 |
| CVE-2018-14626 | 7.5 | Nov 29 | PowerDNS Authoritative Server 4.1.0 up to 4.1.4 inclusive and PowerDNS Recursor 4.0.0 up to 4.1.4 inclusive are vulnerable to a packet cache pollution via crafted query that can… Affected: 4.1.0 through 4.1.4 |
| CVE-2018-10851 | 7.5 | Nov 29 | PowerDNS Authoritative Server 3.3.0 up to 4.1.4 excluding 4.1.5 and 4.0.6, and PowerDNS Recursor 3.2 up to 4.1.4 excluding 4.1.5 and 4.0.9, are vulnerable to a memory leak while… Affected: 3.3 through 4.1.4 |
| CVE-2016-7068 | 7.5 | Sep 11 | An issue has been found in PowerDNS before 3.4.11 and 4.0.2, and PowerDNS recursor before 3.7.4 and 4.0.4, allowing a remote, unauthenticated attacker to cause an abnormal CPU… Affected: before 3.4.11; 4.0.0 before 4.0.2 |
| CVE-2016-7072 | 7.5 | Sep 10 | An issue has been found in PowerDNS Authoritative Server before 3.4.11 and 4.0.2 allowing a remote, unauthenticated attacker to cause a denial of service by opening a large number… Affected: before 3.4.11; 4.0.0 before 4.0.2 |
| CVE-2016-5427 | 7.5 | Sep 21 | PowerDNS (aka pdns) Authoritative Server before 3.4.10 does not properly handle a Affected: through 3.4.9 |
| CVE-2016-5426 | 7.5 | Sep 21 | PowerDNS (aka pdns) Authoritative Server before 3.4.10 allows remote attackers to cause a denial of service (backend CPU consumption) via a long qname Affected: through 3.4.9 |
| CVE-2017-15091 | 7.1 | Jan 23 | An issue has been found in the API component of PowerDNS Authoritative 4.x up to and including 4.0.4 and 3.x up to and including 3.4.11, where some operations that have an impact… Affected: 3.0 through 3.4.11; 4.0.0 through 4.0.4 |
Showing 17
