AU
Product
Authoritative
32
CVEs
0
On KEV
9.8
Max CVSS
0
New 30D
Severity mix
Critical 2High 17Medium 10Low 0
Watch
Add Authoritative to your stack to get only the CVEs that touch what you run.
| CVE | CVSS | Published | Summary · affected versions |
|---|---|---|---|
| CVE-2026-33608 | 9.8 | Apr 22 | Incomplete domain name sanitization during Affected: 5.0.0 before 5.0.4; 4.9.0 before 4.9.14 |
| CVE-2020-24698 | 9.8 | Oct 2 | An issue was discovered in PowerDNS Authoritative through 4.3.0 when --enable-experimental-gss-tsig is used Affected: through 4.3.0 |
| CVE-2026-42000 | 8.6 | May 21 | Insufficient Validation of Names During AXFR Affected: 4.9.0 before 4.9.15; 5.0.0 before 5.0.5 |
| CVE-2020-24696 | 8.1 | Oct 2 | An issue was discovered in PowerDNS Authoritative through 4.3.0 when --enable-experimental-gss-tsig is used Affected: through 4.3.0 |
| CVE-2026-42002 | 7.5 | May 21 | Concurrency and locking defects in GSS-TSIG Affected: 4.9.0 before 4.9.15; 5.0.0 before 5.0.5 |
| CVE-2026-42001 | 7.5 | May 21 | Insufficient Validation of Autoprimary SOA Queries Affected: 4.9.0 before 4.9.15; 5.0.0 before 5.0.5 |
| CVE-2026-33610 | 7.5 | Apr 22 | Possible file descriptor exhaustion in forward-dnsupdate Affected: 5.0.0 before 5.0.4; 4.9.0 before 4.9.14 |
| CVE-2026-33260 | 7.5 | Apr 22 | Insufficient input validation of internal webserver Affected: 5.0.0 before 5.0.4; 4.9.0 before 4.9.14 |
| CVE-2026-33257 | 7.5 | Apr 22 | Insufficient input validation of internal webserver Affected: 5.0.0 before 5.0.4; 4.9.0 before 4.9.14 |
| CVE-2020-24697 | 7.5 | Oct 2 | An issue was discovered in PowerDNS Authoritative through 4.3.0 when --enable-experimental-gss-tsig is used Affected: through 4.3.0 |
| CVE-2015-5230 | 7.5 | Jan 15 | The DNS packet parsing/generation code in PowerDNS (aka pdns) Authoritative Server 3.4.x before 3.4.6 allows remote attackers to cause a denial of service (crash) via crafted… Affected: 3.4.0 before 3.4.6 |
| CVE-2019-10162 | 7.5 | Jul 30 | A vulnerability has been found in PowerDNS Authoritative Server before versions 4.1.10, 4.0.8 allowing an authorized user to cause the server to exit by inserting a crafted record… Affected: 4.0.0 before 4.0.8; 4.1.0 before 4.1.10; 4.0.0 |
| CVE-2018-14626 | 7.5 | Nov 29 | PowerDNS Authoritative Server 4.1.0 up to 4.1.4 inclusive and PowerDNS Recursor 4.0.0 up to 4.1.4 inclusive are vulnerable to a packet cache pollution via crafted query that can… Affected: 4.1.0 through 4.1.4 |
| CVE-2018-10851 | 7.5 | Nov 29 | PowerDNS Authoritative Server 3.3.0 up to 4.1.4 excluding 4.1.5 and 4.0.6, and PowerDNS Recursor 3.2 up to 4.1.4 excluding 4.1.5 and 4.0.9, are vulnerable to a memory leak while… Affected: 3.3 through 4.1.4 |
| CVE-2016-7068 | 7.5 | Sep 11 | An issue has been found in PowerDNS before 3.4.11 and 4.0.2, and PowerDNS recursor before 3.7.4 and 4.0.4, allowing a remote, unauthenticated attacker to cause an abnormal CPU… Affected: before 3.4.11; 4.0.0 before 4.0.2 |
| CVE-2016-7072 | 7.5 | Sep 10 | An issue has been found in PowerDNS Authoritative Server before 3.4.11 and 4.0.2 allowing a remote, unauthenticated attacker to cause a denial of service by opening a large number… Affected: before 3.4.11; 4.0.0 before 4.0.2 |
| CVE-2016-5427 | 7.5 | Sep 21 | PowerDNS (aka pdns) Authoritative Server before 3.4.10 does not properly handle a Affected: through 3.4.9 |
| CVE-2016-5426 | 7.5 | Sep 21 | PowerDNS (aka pdns) Authoritative Server before 3.4.10 allows remote attackers to cause a denial of service (backend CPU consumption) via a long qname Affected: through 3.4.9 |
| CVE-2017-15091 | 7.1 | Jan 23 | An issue has been found in the API component of PowerDNS Authoritative 4.x up to and including 4.0.4 and 3.x up to and including 3.4.11, where some operations that have an impact… Affected: 3.0 through 3.4.11; 4.0.0 through 4.0.4 |
| CVE-2026-42396 | 6.5 | May 21 | Insufficient Validation of Member Zone Data May Cause Catalog Zone Transfer to Fail Affected: 4.9.0 before 4.9.15; 5.0.0 before 5.0.5 |
| CVE-2026-33609 | 6.5 | Apr 22 | LDAP DN injection Affected: 5.0.0 before 5.0.4; 4.9.0 before 4.9.14 |
| CVE-2016-2120 | 6.5 | Nov 1 | An issue has been found in PowerDNS Authoritative Server versions up to and including 3.4.10, 4.0.1 allowing an authorized user to crash the server by inserting a specially… Affected: through 3.4.10; 4.0.0 through 4.0.1 |
| CVE-2016-7074 | 5.9 | Sep 11 | An issue has been found in PowerDNS before 3.4.11 and 4.0.2, and PowerDNS recursor before 4.0.4, allowing an attacker in position of man-in-the-middle to alter the content of an… Affected: before 3.4.11; 4.0.0 before 4.0.2 |
| CVE-2016-7073 | 5.9 | Sep 11 | An issue has been found in PowerDNS before 3.4.11 and 4.0.2, and PowerDNS recursor before 4.0.4, allowing an attacker in position of man-in-the-middle to alter the content of an… Affected: before 3.4.11; 4.0.0 before 4.0.2 |
| CVE-2026-33611 | 4.9 | Apr 22 | Insufficient validation of HTTPS and SVCB records Affected: 5.0.0 before 5.0.4; 4.9.0 before 4.9.14 |
| CVE-2026-41999 | 4.8 | May 21 | Incorrect Behaviour of Views with TCP PROXY Requests Affected: 5.0.0 before 5.0.5 |
| CVE-2026-42005 | 4.3 | Jun 25 | Insufficient input validation of internal web server Affected: 4.9.0 before 4.9.16; 5.0.0 before 5.0.6; 5.1.0 before 5.1.2 |
| CVE-2020-17482 | 4.3 | Oct 2 | An issue has been found in PowerDNS Authoritative Server before 4.3.1 where an authorized user with the ability to insert crafted records into a zone might be able to leak the… Affected: before 4.3.1 |
| CVE-2019-10163 | 4.3 | Jul 30 | A Vulnerability has been found in PowerDNS Authoritative Server before versions 4.1.9, 4.0.8 allowing a remote, authorized master server to cause a high CPU load or even prevent… Affected: 4.0.0 before 4.0.8; 4.1.0 before 4.1.9; 4.1.0 |
| CVE-2015-5311 | – | Nov 17 | PowerDNS (aka pdns) Authoritative Server 3.4.4 before 3.4.7 allows remote attackers to cause a denial of service (assertion failure and server crash) via crafted query packets Affected: 3.4.4; 3.4.5; 3.4.6 |
| CVE-2015-5470 | – | Nov 2 | The label decompression functionality in PowerDNS Recursor before 3.6.4 and 3.7.x before 3.7.3 and Authoritative (Auth) Server before 3.3.3 and 3.4.x before 3.4.5 allows remote… Affected: through 3.3.2; 3.4.0; 3.4.1; 3.4.2; 3.4.3; 3.4.4 |
| CVE-2015-1868 | – | May 18 | The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and 3.7.x before 3.7.2 and Authoritative (Auth) Server 3.2.x, 3.3.x before 3.3.2, and 3.4.x… Affected: 3.2; 3.3; 3.3.1; 3.3.2; 3.4.0; 3.4.1; +1 more |
Showing 32
