XC
Product
Xcode
On CISA KEVExploited in the wild
99
CVEs
1
On KEV
9.8
Max CVSS
4
New 30D
Severity mix
Critical 4High 47Medium 21Low 2
Watch
Add Xcode to your stack to get only the CVEs that touch what you run.
| CVE | CVSS | Published | Summary · affected versions |
|---|---|---|---|
| CVE-2025-48384 In wildKEV | 8.0 | Jul 8 | Git allows arbitrary code execution through broken config quoting Affected: before 26.0 |
| CVE-2026-86949 | 8.8 | Oct 20 | This issue was addressed by enforcing library validation on the affected binaries Affected: before 27 |
| CVE-2025-43505 | 8.8 | Nov 4 | An out-of-bounds write issue was addressed with improved input validation Affected: before 26.1 |
| CVE-2022-39260 | 8.8 | Oct 19 | Git vulnerable to Remote Code Execution via Heap overflow in `git shell` Affected: before 14.1 |
| CVE-2019-8840 | 8.8 | Oct 27 | An out-of-bounds read was addressed with improved bounds checking Affected: before 11.3 |
| CVE-2019-8724 | 8.8 | Dec 18 | Multiple issues in ld64 in the Xcode toolchains were addressed by updating to version ld64-507.4 Affected: before 11.0 |
| CVE-2019-8723 | 8.8 | Dec 18 | Multiple issues in ld64 in the Xcode toolchains were addressed by updating to version ld64-507.4 Affected: before 11.0 |
| CVE-2019-8722 | 8.8 | Dec 18 | Multiple issues in ld64 in the Xcode toolchains were addressed by updating to version ld64-507.4 Affected: before 11.0 |
| CVE-2019-8721 | 8.8 | Dec 18 | Multiple issues in ld64 in the Xcode toolchains were addressed by updating to version ld64-507.4 Affected: before 11.0 |
| CVE-2019-3855 | 8.8 | Mar 21 | An integer overflow flaw which could lead to an out of bounds write was discovered in libssh2 before 1.8.1 in the way packets are read from the server Affected: before 11.0 |
| CVE-2023-27967 | 8.6 | May 8 | The issue was addressed with improved memory handling Affected: before 14.3 |
| CVE-2025-43371 | 8.2 | Sep 15 | This issue was addressed with improved checks Affected: before 26.0 |
| CVE-2024-44162 | 7.8 | Sep 17 | This issue was addressed by enabling hardened runtime Affected: before 16.0 |
| CVE-2023-32396 | 7.8 | Sep 27 | This issue was addressed with improved checks Affected: before 15.0 |
| CVE-2022-42797 | 7.8 | Feb 27 | An injection issue was addressed with improved input validation Affected: before 14.1 |
| CVE-2022-29187 | 7.8 | Jul 12 | Git is a distributed revision control system Affected: before 14.1 |
| CVE-2022-26747 | 7.8 | May 26 | This issue was addressed with improved checks Affected: before 13.4 |
| CVE-2022-24765 | 7.8 | Apr 12 | Git for Windows is a fork of Git containing Windows-specific patches Affected: before 13.4 |
| CVE-2022-22608 | 7.8 | Mar 18 | An out-of-bounds read was addressed with improved bounds checking Affected: before 13.3 |
| CVE-2022-22607 | 7.8 | Mar 18 | An out-of-bounds read was addressed with improved bounds checking Affected: before 13.3 |
| CVE-2022-22606 | 7.8 | Mar 18 | An out-of-bounds read was addressed with improved bounds checking Affected: before 13.3 |
| CVE-2022-22605 | 7.8 | Mar 18 | An out-of-bounds read was addressed with improved bounds checking Affected: before 13.3 |
| CVE-2022-22604 | 7.8 | Mar 18 | An out-of-bounds read was addressed with improved bounds checking Affected: before 13.3 |
| CVE-2022-22603 | 7.8 | Mar 18 | An out-of-bounds read was addressed with improved bounds checking Affected: before 13.3 |
| CVE-2022-22602 | 7.8 | Mar 18 | An out-of-bounds read was addressed with improved bounds checking Affected: before 13.3 |
| CVE-2022-22601 | 7.8 | Mar 18 | An out-of-bounds read was addressed with improved bounds checking Affected: before 13.3 |
| CVE-2020-9992 | 7.8 | Oct 16 | This issue was addressed by encrypting communications over the network to devices running iOS 14, iPadOS 14, tvOS 14, and watchOS 7 Affected: before 12.0 |
| CVE-2019-8806 | 7.8 | Dec 18 | A memory corruption issue was addressed with improved validation Affected: before 11.2 |
| CVE-2019-8800 | 7.8 | Dec 18 | A memory corruption issue was addressed with improved validation Affected: before 11.2 |
| CVE-2019-8739 | 7.8 | Dec 18 | A memory corruption issue was addressed with improved state management Affected: before 11.0 |
| CVE-2019-8738 | 7.8 | Dec 18 | A memory corruption issue was addressed with improved state management Affected: before 11.0 |
| CVE-2018-4357 | 7.8 | Apr 3 | A memory corruption issue was addressed with improved input validation Affected: before 10 |
| CVE-2017-7167 | 7.8 | Apr 3 | An issue was discovered in certain Apple products Affected: before 9.2 |
| CVE-2017-7137 | 7.8 | Oct 23 | An issue was discovered in certain Apple products Affected: through 8.3.3 |
| CVE-2017-7136 | 7.8 | Oct 23 | An issue was discovered in certain Apple products Affected: through 8.3.3 |
| CVE-2017-7135 | 7.8 | Oct 23 | An issue was discovered in certain Apple products Affected: through 8.3.3 |
| CVE-2017-7134 | 7.8 | Oct 23 | An issue was discovered in certain Apple products Affected: through 8.3.3 |
| CVE-2016-4705 | 7.8 | Sep 18 | otool in Apple Xcode before 8 allows local users to gain privileges or cause a denial of service (memory corruption and application crash) via unspecified vectors, a different… Affected: through 7.3.1 |
| CVE-2016-4704 | 7.8 | Sep 18 | otool in Apple Xcode before 8 allows local users to gain privileges or cause a denial of service (memory corruption and application crash) via unspecified vectors, a different… Affected: through 7.3.1 |
| CVE-2016-1765 | 7.8 | Mar 24 | otool in Apple Xcode before 7.3 allows local users to gain privileges or cause a denial of service (memory corruption and application crash) via unspecified vectors Affected: through 7.2.1 |
| CVE-2024-44228 | 7.5 | Oct 28 | This issue was addressed with improved permissions checking Affected: before 16.0 |
| CVE-2021-21300 | 7.5 | Mar 9 | Git is an open-source distributed revision control system Affected: before 12.5 |
| CVE-2018-16844 | 7.5 | Nov 7 | nginx before versions 1.15.6 and 1.14.1 has a vulnerability in the implementation of HTTP/2 that can allow for excessive CPU usage Affected: before 13.0 |
| CVE-2018-16843 | 7.5 | Nov 7 | nginx before versions 1.15.6 and 1.14.1 has a vulnerability in the implementation of HTTP/2 that can allow for excessive memory consumption Affected: before 13.0 |
| CVE-2017-7529 | 7.5 | Jul 13 | Nginx versions since 0.5.6 up to and including 1.13.2 are vulnerable to integer overflow vulnerability in nginx range filter module resulting into leak of potentially sensitive… Affected: before 13.0 |
| CVE-2016-0742 | 7.5 | Feb 15 | The resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to cause a denial of service (invalid pointer dereference and worker process crash) via a… Affected: before 13.0 |
| CVE-2025-43263 | 7.1 | Sep 15 | The issue was addressed with improved checks Affected: before 26.0 |
Showing 47
