High severity · published May 8, 2026
CVE-2026-42271
LiteLLM: Authenticated command execution via MCP stdio test endpoints
In wildKEV
8.8
CVSS
91.4%
EPSS
Yes
On KEV
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)91.4% · higher than 100% of CVEs
Exploited in the wildYes
CISA KEVListed Jun 8, 2026
Federal remediation dueJun 22, 2026
Ransomware campaign useNot known
Affected products
Which versions
LI
litellm · BerriAI
>= 1.74.2, < 1.83.7 · source: vendor, NVD, KEV
OA
Openshift AI · Redhat
2.25 before 2.25.8; 3.3 before 3.3.4; 3.4 · source: NVD
RH
Red Hat OpenShift AI 2.25 · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat OpenShift AI 3.3 · Red Hat
All versions, or not specified · source: CISA
RH
Red Hat OpenShift AI 3.4 · Red Hat
All versions, or not specified · source: CISA
In the news
VulnerabilityCritical
LiteLLM vulnerability under active attack, CISA warns (CVE-2026-42271)
A command injection vulnerability (CVE-2026-42271) in BerryAI’s LiteLLM open-source AI gateway is being exploited by attackers, the US Cybersecurity and Infrastructure Security Agency (CISA) confirmed by adding the flaw to its Known Exploited Vulnerabilities catalog on Monday. About CVE-2026-42271 LiteLLM is an open-source library that provides a unified interface for calling many different large language model APIs using a single (OpenAI) format. It’s used by both developers and enterprises, to avoid vendor lock-in, centrally manage … More →
The post LiteLLM vulnerability under active attack, CISA warns (CVE-2026-42271) appeared first on Help Net Security .
Jun 9, 2026·Help Net Security
VulnerabilityHigh
CISA Adds Two Known Exploited Vulnerabilities to Catalog
CISA has added two new vulnerabilities to its Known Exploited Vulnerabilities (KEV) Catalog , based on evidence of active exploitation.
CVE-2026-42271 BerriAI LiteLLM Command Injection Vulnerability
CVE-2026-50751 Check Point Security Gateway Improper Authentication Vulnerability
These types of vulnerabilities are a frequent attack vector for malicious cyber actors and pose significant risks to the federal enterprise.
Binding Operational Directive (BOD) 22-01: Reducing the Significant Risk of Known Exploited Vulnerabilities established the KEV Catalog as a living list of known Common Vulnerabilities and Exposures (CVEs) that carry significant risk to the federal enterprise. BOD 22-01 requires Federal Civilian Executive Branch (FCEB) agencies to remediate identified vulnerabilities by the due date to protect FCEB networks against active threats. See the BOD 22-01 Fact Sheet for more information.
Although BOD 22-01 only applies to FCEB agencies, CISA strongly urges all organizations to reduce their exposure to cyberattacks by prioritizing timely remediation of KEV Catalog vulnerabilities as part of their vulnerability management practice. CISA will continue to add vulnerabilities to the catalog that meet the specified criteria .
Jun 8, 2026·CISA Advisories
VulnerabilityHigh
[CISA KEV] CVE-2026-42271: BerriAI LiteLLM - BerriAI LiteLLM Command Injection Vulnerability
BerriAI LiteLLM contains a command injection vulnerability that could allow any authenticated user, including holders of low-privilege internal-user keys, to run arbitrary commands on the host.
LILiteLLMCVE-2026-42271
Jun 8, 2026·CISA KEV
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-42271
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-42271
CISA KEV catalogue
https://www.cisa.gov/known-exploited-vulnerabilities-catalog
Product
https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable
Mitigation
https://github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g
Third Party Advisory
https://access.redhat.com/errata/RHSA-2026:27784
Third Party Advisory
https://access.redhat.com/errata/RHSA-2026:28960
Third Party Advisory
https://access.redhat.com/errata/RHSA-2026:30056
Third Party Advisory
https://access.redhat.com/security/cve/CVE-2026-42271
More from litellm
9.8
CVE-2026-42208
LiteLLM: SQL injection in Proxy API key verification
8.8
CVE-2026-33634
Trivy ecosystem supply chain briefly compromised
8.2
CVE-2026-59822
LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback
9.9
CVE-2026-114612
LiteLLM: Privilege Escalation to Proxy Admin via Cross-Domain Reuse of the Salt Key
9.8
CVE-2026-49468
LiteLLM: Authentication Bypass via Host Header Injection
