Critical severity · published May 8, 2026
CVE-2026-42208
LiteLLM: SQL injection in Proxy API key verification
In wildKEV
9.8
CVSS
89.4%
EPSS
Yes
On KEV
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)89.4% · higher than 100% of CVEs
Exploited in the wildYes
CISA KEVListed May 8, 2026
Federal remediation dueMay 11, 2026
Ransomware campaign useNot known
Affected products
Which versions
LI
litellm · BerriAI
>= 1.81.16, < 1.83.7 · source: vendor, NVD, KEV
In the news
VulnerabilityCritical
U.S. CISA adds a flaw in BerriAI LiteLLM to its Known Exploited Vulnerabilities catalog
The U.S. Cybersecurity and Infrastructure Security Agency (CISA) adds a flaw in BerriAI LiteLLM to its Known Exploited Vulnerabilities catalog. The U.S. Cybersecurity and Infrastructure Security Agency (CISA) added a flaw in BerriAI LiteLLM, tracked as CVE-2026-42208 (CVSS score of 9.3), to its Known Exploited Vulnerabilities (KEV) catalog. At the end of April, attackers rapidly exploited the critical [&#8230;]
May 11, 2026·Security Affairs
VulnerabilityHigh
CISA Adds One Known Exploited Vulnerability to Catalog
CISA has added&nbsp;one&nbsp;new vulnerability&nbsp;to its&nbsp; Known Exploited Vulnerabilities (KEV) Catalog , based on evidence of active exploitation. CVE-2026-42208 &nbsp;BerriAI&nbsp;LiteLLM&nbsp;SQL Injection Vulnerability This&nbsp;type&nbsp;of vulnerability is a&nbsp;frequent attack vector&nbsp;for malicious cyber actors and poses&nbsp;significant risks to the federal enterprise. Binding Operational Directive (BOD) 22-01: Reducing the Significant Risk of Known Exploited Vulnerabilities &nbsp;established the KEV Catalog as a living list of known Common Vulnerabilities and Exposures (CVEs) that carry significant risk to the federal enterprise. BOD 22-01 requires Federal Civilian Executive Branch (FCEB) agencies to remediate identified vulnerabilities by the due date to protect FCEB networks against active threats. See the&nbsp; BOD 22-01 Fact Sheet &nbsp;for more information. Although BOD 22-01 only applies to FCEB agencies, CISA strongly urges all organizations to reduce their exposure to cyberattacks by prioritizing&nbsp;timely&nbsp;remediation of&nbsp; KEV Catalog vulnerabilities &nbsp;as part of their vulnerability management practice. CISA will continue to add vulnerabilities to the catalog that meet the&nbsp; specified criteria .&nbsp;
May 8, 2026·CISA Advisories
VulnerabilityHigh
[CISA KEV] CVE-2026-42208: BerriAI LiteLLM - BerriAI LiteLLM SQL Injection Vulnerability
BerriAI LiteLLM contains a SQL injection vulnerability that allows an attacker to read data from the proxy's database and potentially modify it, leading to unauthorized access to the proxy and the credentials it manages.
May 8, 2026·CISA KEV
VulnerabilityCritical
LiteLLM CVE-2026-42208 SQL Injection Exploited within 36 Hours of Disclosure
In yet another instance of threat actors quickly jumping on the exploitation bandwagon, a newly disclosed critical security flaw in BerriAI's LiteLLM Python package has come under active exploitation in the wild within 36 hours of the bug becoming public knowledge. The vulnerability, tracked as CVE-2026-42208 (CVSS score: 9.3), is an SQL injection that could be exploited to modify the underlying
Apr 29, 2026·The Hacker News
VulnerabilityCritical
Hackers are exploiting a critical LiteLLM pre-auth SQLi flaw
Hackers are targeting sensitive information stored in the LiteLLM open-source large-language model (LLM) gateway by exploiting a critical vulnerability  tracked as CVE-2026-42208. [...]
Apr 28, 2026·BleepingComputer
Affected product
LI
litellm
BerriAI
More from litellm
8.8
CVE-2026-42271
LiteLLM: Authenticated command execution via MCP stdio test endpoints
8.8
CVE-2026-33634
Trivy ecosystem supply chain briefly compromised
8.2
CVE-2026-59822
LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback
9.9
CVE-2026-114612
LiteLLM: Privilege Escalation to Proxy Admin via Cross-Domain Reuse of the Salt Key
9.8
CVE-2026-49468
LiteLLM: Authentication Bypass via Host Header Injection