High severity · published Jul 1, 2026
CVE-2026-14181
@fastify/middie standalone engine vulnerable to Denial of Service via malformed percent-encoded paths
7.5
CVSS
0.5%
EPSS
No
On KEV
Description
@fastify/middie versions 9.1.0 through 9.3.2 fail to guard the URL normalization step used by the standalone engine when incoming request paths contain malformed percent-encoded sequences. Inputs such as an incomplete percent escape or a truncated multibyte sequence cause the underlying decoder to throw synchronously, and the exception escapes the middie normalize step and terminates the Node.js process. The bypass affects applications that call middie.run directly on the standalone engine API, causing an immediate denial of service for all connected clients until restart. Applications using the Fastify plugin path are not affected because Fastifys error handler catches the exception. Patches: upgrade to @fastify/middie 9.3.3. Workarounds: migrate from the standalone engine API to the Fastify plugin path, where the framework error handler catches the exception.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 43% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FA
@fastify/middie · @fastify/middie
9.1.0 before 9.3.3 · source: vendor
FA
Fastify/middie · Fastify
9.1.0 before 9.3.3 · source: NVD
Affected product
FA
@fastify/middie
@fastify/middie
More from @fastify/middie
9.1
CVE-2026-112712
@fastify/middie vulnerable to path-scoped middleware bypass via scope prefix mismatch
9.1
CVE-2026-85184
@fastify/middie vulnerable to path-scoped middleware bypass via absolute-form request target
9.1
CVE-2026-14198
@fastify/middie vulnerable to authorization bypass via encoded slash in path parameter values
9.1
CVE-2026-33804
@fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option
9.1
CVE-2026-6270
@fastify/middie vulnerable to middleware authentication bypass in child plugin scopes