Critical severity · published Oct 20, 2026
CVE-2026-112712
@fastify/middie vulnerable to path-scoped middleware bypass via scope prefix mismatch
9.1
CVSS
0.3%
EPSS
No
On KEV
Description
@fastify/middie is the Express-style middleware engine for Fastify. In versions from 9.0.0 through 9.3.5, the use() function joined a path-scoped middleware's mount path to the plugin scope prefix in a way that could diverge from the path Fastify's router serves, most often when the scope prefix ended in a slash, and also for array mount paths and for mount paths written without a leading slash. When the two paths disagreed, the middleware was silently skipped while the route handler still ran, so path-scoped middleware such as authentication, authorization, or rate limiting could be bypassed by a single unauthenticated request. The issue is fixed in @fastify/middie 9.3.6, and users should upgrade to 9.3.6 or later. As a workaround, enforce authorization in a Fastify hook such as preHandler that runs after the router has resolved the request.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 24% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FA
@fastify/middie · @fastify/middie
9.0.0 before 9.3.6 · source: vendor
Affected product
FA
@fastify/middie
@fastify/middie
More from @fastify/middie
9.1
CVE-2026-85184
@fastify/middie vulnerable to path-scoped middleware bypass via absolute-form request target
9.1
CVE-2026-14198
@fastify/middie vulnerable to authorization bypass via encoded slash in path parameter values
9.1
CVE-2026-33804
@fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option
9.1
CVE-2026-6270
@fastify/middie vulnerable to middleware authentication bypass in child plugin scopes
9.1
CVE-2026-2880
@fastify/middie has an improper path normalization vulnerability