Critical severity · published Apr 16, 2026
CVE-2026-33804
@fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option
9.1
CVSS
0.3%
EPSS
No
On KEV
Description
@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 20% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FA
@fastify/middie · @fastify/middie
before 9.3.2 · source: vendor
FA
Fastify/middie · Fastify
before 9.3.2 · source: NVD
Affected product
FA
@fastify/middie
@fastify/middie
More from @fastify/middie
9.1
CVE-2026-112712
@fastify/middie vulnerable to path-scoped middleware bypass via scope prefix mismatch
9.1
CVE-2026-85184
@fastify/middie vulnerable to path-scoped middleware bypass via absolute-form request target
9.1
CVE-2026-14198
@fastify/middie vulnerable to authorization bypass via encoded slash in path parameter values
9.1
CVE-2026-6270
@fastify/middie vulnerable to middleware authentication bypass in child plugin scopes
9.1
CVE-2026-2880
@fastify/middie has an improper path normalization vulnerability