UF
Product
Universal Forwarder
61
CVEs
0
On KEV
9.8
Max CVSS
0
New 30D
Severity mix
Critical 6High 26Medium 24Low 5
Watch
Add Universal Forwarder to your stack to get only the CVEs that touch what you run.
| CVE | CVSS | Published | Summary · affected versions |
|---|---|---|---|
| CVE-2023-27533 | 8.8 | Mar 30 | A vulnerability in input validation exists in curl <8.0 during communication using the TELNET protocol may allow an attacker to pass on maliciously crafted user name and "telnet… Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2023-27534 | 8.8 | Mar 30 | A path traversal vulnerability exists in curl <8.0.0 SFTP implementation causes the tilde (~) character to be wrongly replaced when used as a prefix in the first path element, in… Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2021-30560 | 8.8 | Aug 3 | Use after free in Blink XSLT in Google Chrome prior to 91.0.4472.164 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2022-42915 | 8.1 | Oct 29 | curl before 7.86.0 has a double free Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2022-32156 | 8.1 | Jun 15 | In Splunk Enterprise and Universal Forwarder versions before 9.0, the Splunk command-line interface (CLI) did not validate TLS certificates while connecting to a remote Splunk… Affected: before 9.0 |
| CVE-2022-27778 | 8.1 | Jun 1 | A use of incorrectly resolved name vulnerability fixed in 7.83.1 might remove the wrong file when `--no-clobber` is used together with `--remove-on-error` Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2022-22576 | 8.1 | May 26 | An improper authentication vulnerability exists in curl 7.33.0 to and including 7.82.0 which might allow reuse OAUTH2-authenticated connections without properly making sure that… Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2021-22901 | 8.1 | Jun 11 | curl 7.75.0 through 7.76.1 suffers from a use-after-free vulnerability resulting in already freed memory being used when a TLS 1.3 session ticket arrives over a connection Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2025-20298 | 8.0 | Jun 2 | In Universal Forwarder for Windows versions below 9.4.2, 9.3.4, 9.2.6, and 9.1.9, a new installation of or an upgrade to an affected version can result in incorrect permissions… Affected: 9.1.0 before 9.1.9; 9.2.0 before 9.2.6; 9.3.0 before 9.3.4; 9.4.0 before 9.4.2 |
| CVE-2021-31566 | 7.8 | Aug 23 | An improper link resolution flaw can occur while extracting an archive leading to changing modes, times, access control lists, and flags of a file outside of the archive Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2020-8177 | 7.8 | Dec 14 | curl 7.20.0 through 7.70.0 is vulnerable to improper restriction of names for files and other resources that can lead too overwriting a local file when the -J flag is used Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2022-43551 | 7.5 | Dec 23 | A vulnerability exists in curl <7.87.0 HSTS check that could be bypassed to trick it to keep using HTTP Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2022-42916 | 7.5 | Oct 29 | In curl before 7.86.0, the HSTS check could be bypassed to trick it into staying with HTTP Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2022-35737 | 7.5 | Aug 3 | SQLite 1.0.12 through 3.39.x before 3.39.2 sometimes allows an array-bounds overflow if billions of bytes are used in a string argument to a C API Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2022-27780 | 7.5 | Jun 1 | The curl URL parser wrongly accepts percent-encoded URL separators like '/'when decoding the host name part of a URL, making it a *different* URL usingthe wrong host name when it… Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2022-27782 | 7.5 | Jun 1 | libcurl would reuse a previously created connection even when a TLS or SSHrelated option had been changed that should have prohibited reuse.libcurl keeps previously used… Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2022-27781 | 7.5 | Jun 1 | libcurl provides the `CURLOPT_CERTINFO` option to allow applications torequest details to be returned about a server's certificate chain.Due to an erroneous function, a malicious… Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2022-27775 | 7.5 | Jun 1 | An information disclosure vulnerability exists in curl 7.65.0 to 7.82.0 are vulnerable that by using an IPv6 address that was in the connection pool but with a different zone id… Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2021-22946 | 7.5 | Sep 29 | A user can tell curl >= 7.20.0 and <= 7.78.0 to require a successful upgrade to TLS when speaking to an IMAP, POP3 or FTP server (`--ssl-reqd` on the command line… Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2021-22926 | 7.5 | Aug 5 | libcurl-using applications can ask for a specific client certificate to be used in a transfer Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2020-8169 | 7.5 | Dec 14 | curl 7.62.0 through 7.70.0 is vulnerable to an information disclosure vulnerability that can lead to a partial password being leaked over the network and to the DNS server(s) Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2020-8286 | 7.5 | Dec 14 | curl 7.41.0 through 7.73.0 is vulnerable to an improper check for certificate revocation due to insufficient verification of the OCSP response Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2020-8231 | 7.5 | Dec 14 | Due to use of a dangling pointer, libcurl 7.29.0 through 7.71.1 can use the wrong connection when sending data Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2020-8285 | 7.5 | Dec 14 | curl 7.21.0 to and including 7.73.0 is vulnerable to uncontrolled recursion due to a stack overflow issue in FTP wildcard match parsing Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2019-20838 | 7.5 | Jun 15 | libpcre in PCRE before 8.43 allows a subject buffer over-read in JIT when UTF is disabled, and \X or \R has more than one fixed quantifier, a related issue to CVE-2019-20454 Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
| CVE-2019-20454 | 7.5 | Feb 14 | An out-of-bounds read was discovered in PCRE before 10.34 when the pattern \X is JIT compiled and used to match specially crafted subjects in non-UTF mode Affected: 8.2.0 before 8.2.12; 9.0.0 before 9.0.6; 9.1.0 |
Showing 26
