NE
Product
Nexpose
21
CVEs
0
On KEV
9.8
Max CVSS
0
New 30D
Severity mix
Critical 1High 10Medium 9Low 0
Watch
Add Nexpose to your stack to get only the CVEs that touch what you run.
| CVE | CVSS | Published | Summary · affected versions |
|---|---|---|---|
| CVE-2023-1699 | 9.8 | Mar 30 | Rapid7 Nexpose versions 6.6.186 and below suffer from a forced browsing vulnerability. This vulnerability allows an attacker to manipulate URLs to forcefully browse to and access… Affected: before 6.6.187 |
| CVE-2022-0757 | 8.8 | Mar 17 | Rapid7 Nexpose versions 6.6.93 and earlier are susceptible to an SQL Injection vulnerability, whereby valid search operators are not defined Affected: through 6.6.93 |
| CVE-2019-5630 | 8.8 | Jul 3 | A Cross-Site Request Forgery (CSRF) vulnerability was found in Rapid7 Nexpose InsightVM Security Console versions 6.5.0 through 6.5.68 Affected: 6.5.0 through 6.5.68 |
| CVE-2017-5264 | 8.8 | Dec 14 | Versions of Nexpose prior to 6.4.66 fail to adequately validate the source of HTTP requests intended for the Automated Actions administrative web application, and are susceptible… Affected: before 6.4.66 |
| CVE-2019-5638 | 8.7 | Aug 21 | Rapid7 Nexpose versions 6.5.50 and prior suffer from insufficient session expiration when an administrator performs a security relevant edit on an existing, logged on user Affected: through 6.5.50 |
| CVE-2017-5243 | 8.5 | Jun 6 | The default SSH configuration in Rapid7 Nexpose hardware appliances shipped before June 2017 does not specify desired algorithms for key exchange and other important functions Affected: through 6.4.40 |
| CVE-2020-7383 | 8.1 | Oct 14 | A SQL Injection issue in Rapid7 Nexpose version prior to 6.6.49 that may have allowed an authenticated user with a low permission level to access resources & make changes they… Affected: before 6.6.49 |
| CVE-2026-14172 | 7.8 | Jul 24 | Rapid7 InsightVM, Nexpose, and Insight Agent Local Privilege Escalation via Unvalidated Executable Invocation Affected: before 1.1.3935 |
| CVE-2020-7381 | 7.8 | Sep 3 | In Rapid7 Nexpose installer versions prior to 6.6.40, the Nexpose installer calls an executable which can be placed in the appropriate directory by an attacker with access to the… Affected: before 6.6.40 |
| CVE-2017-5232 | 7.8 | Mar 2 | All editions of Rapid7 Nexpose installers prior to version 6.4.24 contain a DLL preloading vulnerability, wherein it is possible for the installer to load a malicious DLL located… Affected: through 6.4.23 |
| CVE-2017-5230 | 7.2 | Mar 2 | The Java keystore in all versions and editions of Rapid7 Nexpose prior to 6.4.50 is encrypted with a static password of 'r@p1d7k3y5t0r3' which is not modifiable by the user Affected: through 6.4.23 |
| CVE-2022-4261 | 6.5 | Dec 8 | Rapid7 Nexpose and InsightVM versions prior to 6.6.172 failed to reliably validate the authenticity of update contents Affected: before 6.6.172 |
| CVE-2020-7382 | 6.5 | Sep 3 | Rapid7 Nexpose installer version prior to 6.6.40 contains an Unquoted Search Path which may allow an attacker on the local machine to insert an arbitrary file into the executable… Affected: before 6.6.40 |
| CVE-2022-0758 | 6.1 | Mar 17 | Rapid7 Nexpose versions 6.6.129 and earlier suffer from a reflected cross site scripting vulnerability, within the shared scan configuration component of the tool Affected: before 6.6.130 |
| CVE-2021-3535 | 6.1 | Jun 16 | Rapid7 Nexpose is vulnerable to a non-persistent cross-site scripting vulnerability affecting the Security Console's Filtered Asset Search feature Affected: before 6.6.81 |
| CVE-2012-6494 | 6.1 | Jan 25 | Rapid7 Nexpose before 5.5.4 contains a session hijacking vulnerability which allows remote attackers to capture a user's session and gain unauthorized access Affected: before 5.5.4 |
| CVE-2021-31868 | 5.4 | Aug 19 | Rapid7 Nexpose version 6.6.95 and earlier allows authenticated users of the Security Console to view and edit any ticket in the legacy ticketing feature, regardless of the… Affected: before 6.6.96 |
| CVE-2016-9757 | 5.4 | Dec 20 | In the Create Tags page of the Rapid7 Nexpose version 6.4.12 user interface, any authenticated user who has the capability to create tags can inject cross-site scripting (XSS)… Affected: 6.4.12 |
| CVE-2022-3913 | 5.3 | Feb 1 | Rapid7 Nexpose and InsightVM versions 6.6.82 through 6.6.177 fail to validate the certificate of the update server when downloading updates Affected: 6.6.82 before 6.6.178 |
| CVE-2019-5640 | 5.3 | Nov 22 | Rapid7 Nexpose versions prior to 6.6.114 suffer from an information exposure issue whereby, when the user's session has ended due to inactivity, an attacker can use the inspect… Affected: before 6.6.114 |
| CVE-2012-6493 | – | Feb 4 | Cross-site request forgery (CSRF) vulnerability in Rapid7 Nexpose Security Console before 5.5.4 allows remote attackers to hijack the authentication of unspecified victims for… Affected: through 5.5.3; 5.4; 5.4.1; 5.4.2; 5.4.3; 5.4.4; +9 more |
Showing 21
