PE
Product
Puppet Enterprise
89
CVEs
0
On KEV
9.8
Max CVSS
0
New 30D
Severity mix
Critical 8High 14Medium 21Low 0
Watch
Add Puppet Enterprise to your stack to get only the CVEs that touch what you run.
| CVE | CVSS | Published | Summary · affected versions |
|---|---|---|---|
| CVE-2023-5309 | 9.8 | Nov 7 | Versions of Puppet Enterprise prior to 2021.7.6 and 2023.5 contain a flaw which results in broken session management for SAML implementations Affected: before 2021.7.6; 2023.0 before 2023.5.0 |
| CVE-2023-2530 | 9.8 | Jun 7 | A privilege escalation allowing remote code execution was discovered in the orchestration service Affected: 2021.7.0 through 2021.7.3; 2023.0; 2023.1.0 |
| CVE-2021-27023 | 9.8 | Nov 18 | A flaw was discovered in Puppet Agent and Puppet Server that may result in a leak of HTTP credentials when following HTTP redirects to a different host Affected: before 2019.8.9; 2021.0.0 before 2021.4 |
| CVE-2019-10694 | 9.8 | Dec 12 | The express install, which is the suggested way to install Puppet Enterprise, gives the user a URL at the end of the install to set the admin password Affected: 2018.1.0 before 2018.1.9; 2019.0 before 2019.0.3 |
| CVE-2018-11749 | 9.8 | Aug 24 | When users are configured to use startTLS with RBAC LDAP, at login time, the user's credentials are sent via plaintext to the LDAP server Affected: through 2016.4.14; 2017.3.0 through 2017.3.9; 2018.1.0 through 2018.1.3 |
| CVE-2018-6512 | 9.8 | Jun 11 | The previous version of Puppet Enterprise 2018.1 is vulnerable to unsafe code execution when upgrading pe-razor-server Affected: 2018.1.0 before 2018.1.1 |
| CVE-2016-2788 | 9.8 | Feb 13 | MCollective 2.7.0 and 2.8.x before 2.8.9, as used in Puppet Enterprise, allows remote attackers to execute arbitrary code via vectors related to the mco ping command Affected: 3.8.0 before 3.8.6; 2016.2.0 before 2016.2.1 |
| CVE-2016-2786 | 9.8 | Jun 10 | The pxp-agent component in Puppet Enterprise 2015.3.x before 2015.3.3 and Puppet Agent 1.3.x before 1.3.6 does not properly validate server certificates, which might allow remote… Affected: 2015.3.0; 2015.3.2 |
Showing 8
