PH
Product
phpipam
60
CVEs
0
On KEV
9.8
Max CVSS
3
New 30D
Severity mix
Critical 8High 10Medium 38Low 3
Watch
Add phpipam to your stack to get only the CVEs that touch what you run.
| CVE | CVSS | Published | Summary · affected versions |
|---|---|---|---|
| CVE-2024-41355 | 6.5 | Jul 26 | phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via /app/tools/request-ip/index.php Affected: 1.6 |
| CVE-2022-1225 | 6.5 | Apr 4 | Incorrect Privilege Assignment in GitHub repository phpipam/phpipam prior to 1.4.6 Affected: before 1.4.6 |
| CVE-2022-1224 | 6.5 | Apr 4 | Improper Authorization in GitHub repository phpipam/phpipam prior to 1.4.6 Affected: before 1.4.6 |
| CVE-2022-1223 | 6.5 | Apr 4 | Incorrect Authorization in GitHub repository phpipam/phpipam prior to 1.4.6 Affected: before 1.4.6 |
| CVE-2025-61078 | 6.1 | Dec 9 | Cross-site scripting (XSS) vulnerability in Request IP form in phpIPAM v1.7.3 allows remote attackers to inject arbitrary web script or HTML via the instructions parameter for the… Affected: 1.7.3 |
| CVE-2024-10727 | 6.1 | Mar 20 | A reflected cross-site scripting (XSS) vulnerability exists in phpipam/phpipam versions 1.5.0 through 1.6.0 Affected: 1.5.0 through 1.6 |
| CVE-2024-10720 | 6.1 | Mar 20 | A stored cross-site scripting (XSS) vulnerability exists in phpipam/phpipam version 1.5.2 Affected: before 1.7.0 |
| CVE-2024-41358 | 6.1 | Aug 29 | phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via app\admin\import-export\import-load-data.php Affected: 1.6 |
| CVE-2023-24657 | 6.1 | Mar 8 | phpipam v1.6 was discovered to contain a reflected cross-site scripting (XSS) vulnerability via the closeClass parameter at /subnet-masks/popup.php Affected: 1.6 |
| CVE-2023-0677 | 6.1 | Feb 4 | Cross-site Scripting (XSS) - Reflected in GitHub repository phpipam/phpipam prior to v1.5.1 Affected: before 1.5.1 |
| CVE-2023-0676 | 6.1 | Feb 4 | Cross-site Scripting (XSS) - Reflected in GitHub repository phpipam/phpipam prior to 1.5.1 Affected: before 1.5.1 |
| CVE-2022-3845 | 6.1 | Nov 2 | phpipam Import Preview import-load-data.php cross site scripting Affected: before 1.5.0 |
| CVE-2021-46426 | 6.1 | Mar 25 | phpIPAM 1.4.4 allows Reflected XSS and CSRF via app/admin/subnets/find_free_section_subnets.php of the subnets functionality Affected: 1.4.4 |
| CVE-2021-35438 | 6.1 | Jun 23 | phpIPAM 1.4.3 allows Reflected XSS via app/dashboard/widgets/ipcalc-result.php and app/tools/ip-calculator/result.php of the IP calculator Affected: 1.4.3 |
| CVE-2019-1000010 | 6.1 | Feb 4 | phpIPAM version 1.3.2 and earlier contains a Cross Site Scripting (XSS) vulnerability in subnet-scan-telnet.php that can result in executing code in victims browser Affected: through 1.3.2 |
| CVE-2018-10329 | 6.1 | Apr 24 | app/tools/mac-lookup/index.php in phpIPAM 1.3.1 has Reflected XSS on /tools/mac-lookup/ via the mac parameter Affected: 1.3.1 |
| CVE-2017-6481 | 6.1 | Mar 5 | Multiple Cross-Site Scripting (XSS) issues were discovered in phpipam 1.2 Affected: through 1.2 |
| CVE-2024-0787 | 5.9 | Nov 15 | phpIPAM version 1.5.1 contains a vulnerability where an attacker can bypass the IP block mechanism to brute force passwords for users by using the 'X-Forwarded-For' header Affected: before 1.7.0 |
| CVE-2024-10725 | 5.4 | Mar 20 | A stored cross-site scripting (XSS) vulnerability exists in phpipam/phpipam version 1.5.2 Affected: before 1.7.0 |
| CVE-2024-10724 | 5.4 | Mar 20 | A stored cross-site scripting (XSS) vulnerability exists in phpipam/phpipam version 1.5.2, specifically in the Subnet NAT translations section when editing the Destination address Affected: before 1.7.0 |
| CVE-2024-10723 | 5.4 | Mar 20 | A stored cross-site scripting (XSS) vulnerability was discovered in phpipam/phpipam version 1.5.2 Affected: before 1.7.0 |
| CVE-2024-10722 | 5.4 | Mar 20 | A stored cross-site scripting (XSS) vulnerability exists in phpipam/phpipam version 1.5.2 Affected: before 1.7.0 |
| CVE-2024-10721 | 5.4 | Mar 20 | A stored cross-site scripting (XSS) vulnerability was discovered in phpipam/phpipam version 1.5.2 Affected: 1.5.2 |
| CVE-2024-10719 | 5.4 | Mar 20 | A stored cross-site scripting (XSS) vulnerability exists in phpipam version 1.5.2, specifically in the circuits options functionality Affected: before 1.7.0 |
| CVE-2018-1000870 | 5.4 | Dec 20 | PHPipam version 1.3.2 and earlier contains a CWE-79 vulnerability in /app/admin/users/print-user.php that can result in Execute code in the victims browser Affected: through 1.3.2 |
| CVE-2017-15640 | 5.4 | Apr 21 | app/sections/user-menu.php in phpIPAM before 1.3.1 has XSS via the ip parameter Affected: before 1.3.1 |
| CVE-2023-0678 | 5.3 | Feb 4 | Missing Authorization in GitHub repository phpipam/phpipam prior to v1.5.1 Affected: before 1.5.1 |
| CVE-2022-1226 | 4.8 | Nov 15 | A Cross-Site Scripting (XSS) vulnerability in phpipam/phpipam versions prior to 1.4.7 allows attackers to execute arbitrary JavaScript code in the browser of a victim Affected: before 1.4.7 |
| CVE-2023-4965 | 4.8 | Sep 14 | A vulnerability was found in phpipam 1.5.1 Affected: 1.5.1 |
| CVE-2023-1212 | 4.8 | Mar 7 | Cross-site Scripting (XSS) - Stored in GitHub repository phpipam/phpipam prior to v1.5.2 Affected: before 1.5.2 |
| CVE-2022-23045 | 4.8 | Jan 19 | PhpIPAM v1.4.4 allows an authenticated admin user to inject persistent JavaScript code inside the "Site title" parameter while updating the site settings Affected: 1.4.4 |
| CVE-2020-13225 | 4.8 | May 20 | phpIPAM 1.4 contains a stored cross site scripting (XSS) vulnerability within the Edit User Instructions field of the User Instructions widget Affected: 1.4 |
| CVE-2026-4189 | 4.7 | Mar 15 | phpipam Section edit-result.php sql injection Affected: 1.7.0; 1.7.1; 1.7.2; 1.7.3; 1.7.4 |
| CVE-2024-55093 | 4.7 | Mar 31 | phpIPAM through 1.7.3 has a reflected Cross-Site Scripting (XSS) vulnerability in the install scripts Affected: through 1.7.3 |
| CVE-2024-41356 | 4.7 | Jul 26 | phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via app\admin\firewall-zones\zones-edit-network.php Affected: 1.6 |
| CVE-2018-1000860 | 4.7 | Dec 20 | phpipam version 1.3.2 and earlier contains a Cross Site Scripting (XSS) vulnerability in The value of the phpipamredirect cookie is copied into an HTML tag on the login page… Affected: through 1.3.2 |
| CVE-2026-115982 New | 4.3 | Oct 24 | phpIPAM Rack Link Creation show-rack-popup.php create_rack_link cross site scripting Affected: 1.8.0; 1.8.1; 1.8.2; 1.8.3 |
| CVE-2026-108720 | 4.3 | Oct 11 | phpIPAM through 1.8.3 Missing Authorization in Customers, Locations and NAT Pages Affected: through 1.8.3 |
Showing 38
