HS
Product
Http Server
On CISA KEVExploited in the wildRansomware-linked
111
CVEs
4
On KEV
10.0
Max CVSS
0
New 30D
Severity mix
Critical 25High 36Medium 20Low 4
Watch
Add Http Server to your stack to get only the CVEs that touch what you run.
| CVE | CVSS | Published | Summary · affected versions |
|---|---|---|---|
| CVE-2021-4034 RansomwareIn wildKEV | 7.8 | Jan 28 | Red Hat Polkit Out-of-Bounds Read and Write Vulnerability Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2019-0211 In wildKEV | 7.8 | Apr 8 | Apache HTTP Server Privilege Escalation Vulnerability Affected: 12.2.1.3.0 |
| CVE-2026-34291 | 8.7 | Apr 21 | Vulnerability in the Oracle HTTP Server product of Oracle Fusion Middleware (component: Core) Affected: 12.2.1.4.0; 14.1.2.0.0 |
| CVE-2026-60431 | 8.6 | Jul 21 | Vulnerability in the Oracle HTTP Server product of Oracle Fusion Middleware (component: mod_proxy) Affected: 12.2.1.4.0; 14.1.2.0.0 |
| CVE-2021-44224 | 8.2 | Dec 20 | A crafted URI sent to httpd configured as a forward proxy (ProxyRequests on) can cause a crash (NULL pointer dereference) or, for configurations mixing forward and reverse proxy… Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2020-35164 | 8.1 | Jul 11 | Dell BSAFE Crypto-C Micro Edition, versions before 4.1.5, and Dell BSAFE Micro Edition Suite, versions before 4.6, contain an Observable Timing Discrepancy Vulnerability Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2026-60530 | 7.8 | Jul 21 | Vulnerability in the Oracle HTTP Server product of Oracle Fusion Middleware (component: mod_http2.so) Affected: 14.1.2.0.0 |
| CVE-2026-60454 | 7.8 | Jul 21 | Vulnerability in the Oracle HTTP Server product of Oracle Fusion Middleware (component: Core) Affected: 12.2.1.4.0; 14.1.2.0.0 |
| CVE-2019-5443 | 7.8 | Jul 2 | A non-privileged user or program can put code and a config file in a known non-privileged path (under C:/usr/local/) that will make curl <= 7.65.1 automatically run the code (as… Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2019-2414 | 7.8 | Jan 16 | Vulnerability in the Oracle HTTP Server component of Oracle Fusion Middleware (subcomponent: Web Listener) Affected: 12.2.1.3.0 |
| CVE-2023-22019 | 7.5 | Oct 17 | Vulnerability in the Oracle HTTP Server product of Oracle Fusion Middleware (component: Web Listener) Affected: 12.2.1.4.0 |
| CVE-2020-26185 | 7.5 | Jun 1 | Dell BSAFE Micro Edition Suite, versions prior to 4.5.1, contain a Buffer Over-Read Vulnerability Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2020-26184 | 7.5 | Jun 1 | Dell BSAFE Micro Edition Suite, versions prior to 4.5.1, contain an Improper Certificate Validation vulnerability Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2022-22719 | 7.5 | Mar 14 | A carefully crafted request body can cause a read to a random memory area which could cause the process to crash Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2022-21716 | 7.5 | Mar 3 | Twisted is an event-based framework for internet applications, supporting Python 3.6+ Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2022-25314 | 7.5 | Feb 18 | In Expat (aka libexpat) before 2.4.5, there is an integer overflow in copyString Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2022-0391 | 7.5 | Feb 9 | A flaw was found in Python, specifically within the urllib.parse module Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2021-4185 | 7.5 | Dec 30 | Infinite loop in the RTMPT dissector in Wireshark 3.6.0 and 3.4.0 to 3.4.10 allows denial of service via packet injection or crafted capture file Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2021-4184 | 7.5 | Dec 30 | Infinite loop in the BitTorrent DHT dissector in Wireshark 3.6.0 and 3.4.0 to 3.4.10 allows denial of service via packet injection or crafted capture file Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2021-4182 | 7.5 | Dec 30 | Crash in the RFC 7468 dissector in Wireshark 3.6.0 and 3.4.0 to 3.4.10 allows denial of service via packet injection or crafted capture file Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2021-4181 | 7.5 | Dec 30 | Crash in the Sysdig Event dissector in Wireshark 3.6.0 and 3.4.0 to 3.4.10 allows denial of service via packet injection or crafted capture file Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2021-42717 | 7.5 | Dec 7 | ModSecurity 3.x through 3.0.5 mishandles excessively nested JSON objects Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2021-36160 | 7.5 | Sep 16 | A carefully crafted request uri-path can cause mod_proxy_uwsgi to read above the allocated memory and crash (DoS) Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2021-34798 | 7.5 | Sep 16 | Malformed requests may cause the server to dereference a NULL pointer Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2020-5360 | 7.5 | Dec 16 | Dell BSAFE Micro Edition Suite, versions prior to 4.5, are vulnerable to a Buffer Under-Read Vulnerability Affected: 11.1.1.9.0; 12.1.3.0; 12.2.1.4.0 |
| CVE-2020-1967 | 7.5 | Apr 21 | Segmentation fault in SSL_check_chain Affected: 12.2.1.4.0 |
| CVE-2018-20843 | 7.5 | Jun 24 | In libexpat in Expat before 2.2.7, XML input including XML names that contain a large number of colons could make the XML parser consume a high amount of RAM and CPU resources… Affected: 12.1.3.0; 12.2.1.4.0 |
| CVE-2019-0217 | 7.5 | Apr 8 | In Apache HTTP Server 2.4 release 2.4.38 and prior, a race condition in mod_auth_digest when running in a threaded server could allow a user with valid credentials to authenticate… Affected: 12.2.1.3.0 |
| CVE-2018-16890 | 7.5 | Feb 6 | libcurl versions from 7.36.0 to before 7.64.0 is vulnerable to a heap buffer out-of-bounds read Affected: 12.2.1.3.0 |
| CVE-2019-3823 | 7.5 | Feb 6 | libcurl versions from 7.34.0 to before 7.64.0 are vulnerable to a heap out-of-bounds read in the code handling the end-of-response for SMTP Affected: 12.2.1.3.0 |
| CVE-2009-1955 | 7.5 | Jun 8 | The expat XML parser in the apr_xml_* interface in xml/apr_xml.c in Apache APR-util before 1.3.7, as used in the mod_dav and mod_dav_svn modules in the Apache HTTP Server, allows… Affected: All versions, or not specified |
| CVE-2019-10097 | 7.2 | Sep 26 | In Apache HTTP Server 2.4.32-2.4.39, when mod_remoteip was configured to use a trusted intermediary proxy server using the "PROXY" protocol, a specially crafted PROXY header could… Affected: 12.2.1.4.0 |
| CVE-2022-21593 | 7.1 | Oct 18 | Vulnerability in the Oracle HTTP Server product of Oracle Fusion Middleware (component: OHS Config MBeans) Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2021-43818 | 7.1 | Dec 13 | lxml is a library for processing XML and HTML in the Python language Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2021-35940 | 7.1 | Aug 23 | An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613) Affected: 12.2.1.3.0; 12.2.1.4.0 |
| CVE-2021-41617 | 7.0 | Sep 26 | sshd in OpenSSH 6.2 through 8.x before 8.8, when certain non-default configurations are used, allows privilege escalation because supplemental groups are not initialized as… Affected: 12.2.1.2.0; 12.2.1.3.0; 12.2.1.4.0 |
Showing 36
