MY
Product
myCred
11
CVEs
0
On KEV
9.8
Max CVSS
3
New 30D
Severity mix
Critical 1High 0Medium 10Low 0
Watch
Add myCred to your stack to get only the CVEs that touch what you run.
| CVE | CVSS | Published | Summary · affected versions |
|---|---|---|---|
| CVE-2024-43354 | 9.8 | Aug 19 | WordPress myCred plugin <= 2.7.2 - PHP Object Injection vulnerability Affected: through 2.7.2 |
| CVE-2026-40794 | 6.5 | Jun 15 | WordPress myCred plugin <= 3.0.3 - Broken Access Control vulnerability Affected: through 3.0.3 |
| CVE-2026-42676 | 6.5 | Jun 1 | WordPress myCred plugin <= 3.0.4 - Cross Site Scripting (XSS) vulnerability Affected: through 3.0.4 |
| CVE-2021-25015 | 6.1 | Jan 24 | The myCred WordPress plugin before 2.4 does not sanitise and escape the search query before outputting it back in the history dashboard page, leading to a Reflected Cross-Site… Affected: before 2.4 |
| CVE-2017-20008 | 6.1 | Nov 29 | The myCred WordPress plugin before 1.7.8 does not sanitise and escape the user parameter before outputting it back in the Points Log admin dashboard, leading to a Reflected… Affected: before 1.7.8 |
| CVE-2026-114698 | 5.4 | Oct 22 | WordPress myCred plugin <= 4.0.0-beta.1 - Insecure Direct Object References (IDOR) vulnerability Affected: through 4.0.0-beta.1 |
| CVE-2024-10187 | 5.4 | Nov 8 | myCred <= 2.7.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via mycred_link Shortcode Affected: before 2.7.5 |
| CVE-2026-97073 New | 5.3 | Oct 29 | WordPress myCred plugin <= 4.0.2 - Broken Access Control vulnerability Affected: through 4.0.2 |
| CVE-2024-8658 | 5.3 | Sep 25 | myCred – Loyalty Points and Rewards plugin for WordPress and WooCommerce – Give Points, Ranks, Badges, Cashback, WooCommerce rewards, and WooCommerce credits for Gamification <= 2.7.3 - Missing Authorization to Unauthenticated Database Upgrade Affected: before 2.7.4 |
| CVE-2024-43214 | 5.3 | Aug 26 | WordPress myCred plugin <= 2.7.2 - Sensitive Data Exposure vulnerability Affected: through 2.7.2 |
| CVE-2026-115962 New | 4.3 | Oct 29 | WordPress myCred plugin <= 4.0.1 - Bypass Vulnerability vulnerability Affected: through 4.0.1 |
Showing 11
