ME
Product
Mercurial
19
CVEs
0
On KEV
9.8
Max CVSS
0
New 30D
Severity mix
Critical 6High 8Medium 2Low 0
Watch
Add Mercurial to your stack to get only the CVEs that touch what you run.
| CVE | CVSS | Published | Summary · affected versions |
|---|---|---|---|
| CVE-2014-9390 | 9.8 | Feb 12 | Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 on Windows and OS X; Mercurial before 3.2.3 on Windows and OS X; Apple Xcode… Affected: before 3.2.3 |
| CVE-2018-13347 | 9.8 | Jul 6 | mpatch.c in Mercurial before 4.6.1 mishandles integer addition and subtraction, aka OVE-20180430-0002 Affected: before 4.6.1 |
| CVE-2017-17458 | 9.8 | Dec 7 | In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the form of a .git/hooks/post-update script… Affected: before 4.4.1 |
| CVE-2017-1000116 | 9.8 | Oct 5 | Mercurial prior to 4.3 did not adequately sanitize hostnames passed to ssh, leading to possible shell-injection attacks Affected: before 4.3 |
| CVE-2018-17983 | 9.1 | Oct 4 | cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry Affected: before 4.7.2 |
| CVE-2018-1000132 | 9.1 | Mar 14 | Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access Affected: before 4.5.1 |
| CVE-2017-9462 | 8.8 | Jun 6 | In Mercurial before 4.1.3, "hg serve --stdio" allows remote authenticated users to launch the Python debugger, and consequently execute arbitrary code, by using --debugger as a… Affected: before 4.1.3 |
| CVE-2016-3105 | 8.8 | May 9 | The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name Affected: through 3.7.3 |
| CVE-2016-3630 | 8.8 | Apr 13 | The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a (1) clone, (2) push, or (3) pull command, related to (a) a list sizing… Affected: through 3.7.2 |
| CVE-2016-3069 | 8.8 | Apr 13 | Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a crafted name when converting a Git repository Affected: through 3.7.2 |
| CVE-2016-3068 | 8.8 | Apr 13 | Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a crafted git ext:: URL when cloning a subrepository Affected: through 3.7.2 |
| CVE-2018-13348 | 7.5 | Jul 6 | The mpatch_decode function in mpatch.c in Mercurial before 4.6.1 mishandles certain situations where there should be at least 12 bytes remaining after the current position in the… Affected: before 4.6.1 |
| CVE-2018-13346 | 7.5 | Jul 6 | The mpatch_apply function in mpatch.c in Mercurial before 4.6.1 incorrectly proceeds in cases where the fragment start is past the end of the original data, aka OVE-20180430-0004 Affected: before 4.6.1 |
| CVE-2017-1000115 | 7.5 | Oct 5 | Mercurial prior to version 4.3 is vulnerable to a missing symlink check that can malicious repositories to modify files outside the repository Affected: before 4.3 |
| CVE-2010-4237 | 5.9 | Oct 29 | Mercurial before 1.6.4 fails to verify the Common Name field of SSL certificates which allows remote attackers who acquire a certificate signed by a Certificate Authority to… Affected: before 1.6.4 |
| CVE-2019-3902 | 5.9 | Apr 22 | A flaw was found in Mercurial before 4.9 Affected: before 4.9 |
| CVE-2014-9462 | – | Mar 31 | The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command Affected: through 3.2.3 |
| CVE-2008-4297 | – | Sep 27 | Mercurial before 1.0.2 does not enforce the allowpull permission setting for a pull operation from hgweb, which allows remote attackers to read arbitrary files from a repository… Affected: through 1.0.1 |
| CVE-2008-2942 | – | Jun 30 | Directory traversal vulnerability in patch.py in Mercurial 1.0.1 allows user-assisted attackers to modify arbitrary files via ".." (dot dot) sequences in a patch file Affected: 1.0.1 |
Showing 19
