PR
Product
Portable Runtime
9
CVEs
0
On KEV
9.8
Max CVSS
0
New 30D
Severity mix
Critical 2High 3Medium 1Low 0
Watch
Add Portable Runtime to your stack to get only the CVEs that touch what you run.
| CVE | CVSS | Published | Summary · affected versions |
|---|---|---|---|
| CVE-2022-28331 | 9.8 | Jan 31 | On Windows, Apache Portable Runtime 1.7.0 and earlier may write beyond the end of a stack based buffer in apr_socket_sendv() Affected: through 1.7.0 |
| CVE-2022-24963 | 9.8 | Jan 31 | Integer Overflow or Wraparound vulnerability in apr_encode functions of Apache Portable Runtime (APR) allows an attacker to write beyond bounds of a buffer Affected: 1.7.0 |
| CVE-2009-2699 | 7.5 | Oct 13 | The Solaris pollset feature in the Event Port backend in poll/unix/port.c in the Apache Portable Runtime (APR) library before 1.3.9, as used in the Apache HTTP Server before… Affected: before 1.3.9 |
| CVE-2021-35940 | 7.1 | Aug 23 | An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613) Affected: 1.7.0 |
| CVE-2017-12613 | 7.1 | Oct 24 | When apr_time_exp*() or apr_os_exp_time*() functions are invoked with an invalid month field value in Apache Portable Runtime APR 1.6.2 and prior, out of bounds memory may be… Affected: before 1.7.0 |
| CVE-2023-49582 | 5.5 | Aug 26 | Lax permissions set by the Apache Portable Runtime library on Unix platforms would allow local users read access to named shared memory segments, potentially revealing sensitive… Affected: 0.9.0 before 1.7.5 |
| CVE-2012-0840 | – | Feb 10 | tables/apr_hash.c in the Apache Portable Runtime (APR) library through 1.4.5 computes hash values without restricting the ability to trigger hash collisions predictably, which… Affected: through 1.4.5; 0.9.1; 0.9.2; 0.9.2-dev; 0.9.3; 0.9.3-dev; +29 more |
| CVE-2011-0419 | – | May 16 | Stack consumption vulnerability in the fnmatch implementation in apr_fnmatch.c in the Apache Portable Runtime (APR) library before 1.4.3 and the Apache HTTP Server before 2.2.18,… Affected: before 1.4.3 |
| CVE-2009-2412 | – | Aug 6 | Multiple integer overflows in the Apache Portable Runtime (APR) library and the Apache Portable Utility library (aka APR-util) 0.9.x and 1.3.x allow remote attackers to cause a… Affected: 0.9.1; 0.9.2; 0.9.2-dev; 0.9.3; 0.9.3-dev; 0.9.4; +18 more |
Showing 9
