HT
Product
https://github.com/rails/rails
by · last CVE Feb 9, 2023
10
CVEs
0
On KEV
9.8
Max CVSS
0
New 30D
Severity mix
Critical 2High 5Medium 3Low 0
Watch

Add https://github.com/rails/rails to your stack to get only the CVEs that touch what you run.

CVECVSSEPSSPublishedSummary · affected versions
CVE-2022-32224
9.8
3%
Dec 5
A possible escalation to RCE vulnerability exists when using YAML serialized columns in Active Record < 7.0.3.1, <6.1.6.1, <6.0.5.1 and <5.2.8.1 which could allow an attacker,…
Affected: 7.0.3.1, 6.1.6.1, 6.0.5.1, 5.2.8.1
CVE-2022-21831
9.8
3%
May 26
A code injection vulnerability exists in the Active Storage >= v5.2.0 that could allow an attacker to execute code via image_processing arguments
Affected: 7.0.2.3, 6.1.4.7, 6.0.4.7, 5.2.6.3
CVE-2023-22794
8.8
2%
Feb 9
A vulnerability in ActiveRecord <6.0.6.1, v6.1.7.1 and v7.0.4.1 related to the sanitization of comments
Affected: 6.0.6.1, 6.1.7.1, 7.0.4.1
CVE-2023-22792
7.5
2%
Feb 9
A regular expression based DoS vulnerability in Action Dispatch <6.0.6.1,< 6.1.7.1, and <7.0.4.1
Affected: 6.0.6.1, 6.1.7.1, 7.0.4.1
CVE-2022-44566
7.5
1%
Feb 9
A denial of service vulnerability present in ActiveRecord's PostgreSQL adapter <7.0.4.1 and <6.1.7.1
Affected: 7.0.4.1, 6.1.7.1
CVE-2023-22795
7.5
2%
Feb 9
A regular expression based DoS vulnerability in Action Dispatch <6.1.7.1 and <7.0.4.1 related to the If-None-Match header
Affected: 6.1.7.1, 7.0.4.1
CVE-2023-22796
7.5
2%
Feb 9
A regular expression based DoS vulnerability in Active Support <6.1.7.1 and <7.0.4.1
Affected: 6.1.7.1, 7.0.4.1
CVE-2023-22797
6.1
1%
Feb 9
An open redirect vulnerability is fixed in Rails 7.0.4.1 with the new protection against open redirects from calling redirect_to with untrusted user input
Affected: 7.0.4.1
CVE-2022-27777
6.1
2%
May 26
A XSS Vulnerability in Action View tag helpers >= 5.2.0 and < 5.2.0 which would allow an attacker to inject content if able to control input into specific attributes
Affected: 7.0.2.4, 6.1.5.1, 6.0.4.8, 5.2.7.1
CVE-2022-22577
6.1
2%
May 26
An XSS Vulnerability in Action Pack >= 5.2.0 and < 5.2.0 that could allow an attacker to bypass CSP for non HTML like responses
Affected: 7.0.2.4, 6.1.5.1, 6.0.4.8, 5.2.7.1
Showing 10