High severity · published Sep 9, 2026
CVE-2026-74761
Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Spoofing of RemoveSubscription clientId
7.5
CVSS
0.6%
EPSS
No
On KEV
Description
Improper input validation in TopicRegion in Apache ActiveMQ, Apache ActiveMQ Broker, and Apache ActiveMQ All on all platforms.
An authenticated client can spoof clientId when removing a durable topic subscription.
This issue affects Apache ActiveMQ Broker: before 5.19.11, from 6.0.0 before 6.3.2; Apache ActiveMQ All: before 5.19.11, from 6.0.0 before 6.3.2; Apache ActiveMQ: before 5.19.11, from 6.0.0 before 6.3.2.
Users are recommended to upgrade to version 6.3.2 or 5.19.11 which fixes the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 50% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AC
ActiveMQ · Apache
6.0.0 before 6.3.2; before 5.19.11 · source: vendor, NVD
AA
Apache ActiveMQ All · Apache Software Foundation
6.0.0 before 6.3.2; before 5.19.11 · source: vendor
AA
Apache ActiveMQ Broker · Apache Software Foundation
6.0.0 before 6.3.2; before 5.19.11 · source: vendor
AA
Activemq All · Apache
before 5.19.11; 6.0.0 before 6.3.2 · source: NVD
AB
Activemq Broker · Apache
before 5.19.11; 6.2.0 before 6.3.2 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-74761
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-74761
Mailing List
https://lists.apache.org/thread/n9md06jo7ccqmj2mntx4kpcl2d5xqntz
Mailing List
http://www.openwall.com/lists/oss-security/2026/09/08/12
More from ActiveMQ
9.8
CVE-2023-46604
Apache ActiveMQ, Apache ActiveMQ Legacy OpenWire Module: Unbounded deserialization causes ActiveMQ to be vulnerable to a remote code execution (RCE) attack
9.8
CVE-2016-3088
The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote attackers to upload and execute arbitrary files via an HTTP PUT followed by an HTTP MOVE request
8.8
CVE-2026-34197
Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans
9.9
CVE-2021-21345
XStream is vulnerable to a Remote Command Execution attack
9.8
CVE-2021-21350
XStream is vulnerable to an Arbitrary Code Execution attack
