High severity · published Apr 7, 2026
CVE-2026-34197
Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans
In wildKEV
8.8
CVSS
98.3%
EPSS
Yes
On KEV
Description
Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ.
Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including
BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String).
An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext.
Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec().
This issue affects Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ All: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.3.
Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)98.3% · higher than 100% of CVEs
Exploited in the wildYes
CISA KEVListed Apr 16, 2026
Federal remediation dueApr 30, 2026
Ransomware campaign useNot known
Affected products
Which versions
AC
ActiveMQ · Apache
before 5.19.4; 6.0.0 before 6.2.3 · source: vendor, NVD, KEV
AA
Apache ActiveMQ All · Apache Software Foundation
before 5.19.4; 6.0.0 before 6.2.3 · source: vendor
AA
Apache ActiveMQ Broker · Apache Software Foundation
before 5.19.4; 6.0.0 before 6.2.3 · source: vendor
AB
Activemq Broker · Apache
before 5.19.4; 6.0.0 before 6.2.3 · source: NVD
RH
Red Hat JBoss Enterprise Application Platform Expansion Pack · Red Hat
All versions, or not specified · source: CISA
In the news
VulnerabilityHigh
Hitachi Energy SOI
View CSAF
Summary
Hitachi Energy is aware of RCE (Remote Code Execution) vulnerability in Apache ActiveMQ component of SOI product versions listed in this document. These vulnerabilities can be exploited to carry out various attacks affecting confidentiality, integrity, and availability of the product. Please refer to the Recommended Immediate Actions for information about the mitigation/remediation.
The following versions of Hitachi Energy SOI are affected:
SOI vers:SOI/>=2.0.0|<=2.2.0 (CVE-2026-34197)
CVSS
Vendor
Equipment
v3 8.8
Hitachi Energy
SOI
1 Vulnerability
Improper Control of Generation of Code ('Code Injection')
Background
Critical Infrastructure Sectors: Energy
Countries/Areas Deployed: Worldwide
Company Headquarters Location: Switzerland
Vulnerabilities
CVE-2026-34197
Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ used in SOI product. Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String). An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter t...
Oct 6, 2026·CISA Advisories
VulnerabilityHigh
[CISA KEV] CVE-2026-34197: Apache ActiveMQ - Apache ActiveMQ Improper Input Validation Vulnerability
Apache ActiveMQ contains an improper input validation vulnerability that allows for code injection.
ACActiveMQCVE-2026-34197
Apr 16, 2026·CISA KEV
VulnerabilityHigh
Claude helps researcher dig up decade-old Apache ActiveMQ RCE vulnerability (CVE-2026-34197)
In the latest demonstration of how AI assistants can help with bug hunting, Horizon3.ai researcher Naveen Sunkavally used Claude to unearth CVE-2026-34197, a remote code execution vulnerability in Apache ActiveMQ that’s been introduced in the codebase 13 years ago. The vulnerability was patched in late March 2026 and there’s currently no indication that it is being actively exploited by attackers. Neveretheless, with ActiveMQ vulnerabilities having been previously leveraged for ransomware and malware attacks, organizations should … More →
The post Claude helps researcher dig up decade-old Apache ActiveMQ RCE vulnerability (CVE-2026-34197) appeared first on Help Net Security .
Apr 9, 2026·Help Net Security
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-34197
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-34197
CISA KEV catalogue
https://www.cisa.gov/known-exploited-vulnerabilities-catalog
vendor-advisory
https://activemq.apache.org/security-advisories.data/CVE-2026-34197-announcement.txt
More from ActiveMQ
9.8
CVE-2023-46604
Apache ActiveMQ, Apache ActiveMQ Legacy OpenWire Module: Unbounded deserialization causes ActiveMQ to be vulnerable to a remote code execution (RCE) attack
9.8
CVE-2016-3088
The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote attackers to upload and execute arbitrary files via an HTTP PUT followed by an HTTP MOVE request
9.9
CVE-2021-21345
XStream is vulnerable to a Remote Command Execution attack
9.8
CVE-2021-21350
XStream is vulnerable to an Arbitrary Code Execution attack
9.8
CVE-2021-21344
XStream is vulnerable to an Arbitrary Code Execution attack
