Medium severity · published Aug 17, 2026
CVE-2026-71486
vLLM: Derender endpoints decode caller-supplied GenerateResponse token IDs without output bounds
4.3
CVSS
0.4%
EPSS
No
On KEV
Description
vLLM is an inference and serving engine for large language models. Prior to 0.26.0, the /v1/completions/derender and /v1/chat/completions/derender endpoints accept caller-supplied GenerateResponse objects whose generate_responses, choices, token_ids, prompt_logprobs, logprobs.content, top_logprobs, and routed_experts structures are processed by OnlineDerenderer and tokenizer.decode before max_model_len, max_tokens, max_num_seqs, or response-size limits are enforced, allowing an authenticated API client to consume excessive CPU and memory and produce oversized responses. This issue is fixed in version 0.26.0.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
None
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 31% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
VL
vllm · vllm-project
< 0.26.0 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-71486
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-71486
Patch
https://github.com/vllm-project/vllm/commit/8e61b646e2d157f9b93451fa048f9c8530c8a67b
Issue Tracking
https://github.com/vllm-project/vllm/pull/47260
Release Notes
https://github.com/vllm-project/vllm/releases/tag/v0.26.0
Exploit
https://github.com/vllm-project/vllm/security/advisories/GHSA-8737-qx52-hjff
More from vllm
9.8
CVE-2026-115915
vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE
9.8
CVE-2026-25960
SSRF Protection Bypass in vLLM
9.8
CVE-2026-22778
vLLM leaks a heap address when PIL throws an error
9.8
CVE-2026-22807
vLLM affected by RCE via auto_map dynamic module loading during model initialization
9.8
CVE-2024-9053
vllm-project vllm version 0.6.0 contains a vulnerability in the AsyncEngineRPCServer() RPC server entrypoints
