High severity · published Oct 26, 2026
CVE-2026-115915
vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE
New
8.1
CVSS
0.6%
EPSS
No
On KEV
Description
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
High
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 50% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
VL
vllm · vllm-project
< 0.32.0 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-115915
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-115915
github.com
https://github.com/vllm-project/vllm/commit/710ac56e691d4713feca50a43e6c440f07d373fd
github.com
https://github.com/vllm-project/vllm/pull/60022
github.com
https://github.com/vllm-project/vllm/releases/tag/v0.32.0
github.com
https://github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-j82p-2c3h
More from vllm
9.8
CVE-2024-9053
vllm-project vllm version 0.6.0 contains a vulnerability in the AsyncEngineRPCServer() RPC server entrypoints
9.1
CVE-2026-48746
vLLM: OpenAI auth bypass
8.8
CVE-2026-54232
vLLM: Dependency Confusion Vulnerability in vLLM Dockerfile
8.8
CVE-2026-27893
vLLM's hardcoded trust_remote_code=True in NemotronVL and KimiK25 bypasses user security opt-out
8.2
CVE-2026-116176
vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector
