High severity · published Sep 25, 2026
CVE-2026-61525
Zammad: Arbitrary File Deletion via Unvalidated Session Identifier in Long Polling Controller
8.8
CVSS
0.4%
EPSS
No
On KEV
Description
Zammad is a web based open source helpdesk/customer support system. In 7.0.2 and 7.1.0, zammad's session management for websocket and long-polling connections is susceptible to a path traversal attack. Session identifiers supplied by the client are insufficiently validated before being used to construct internal file paths. When the file-based session store is active (the default configuration), an authenticated attacker can manipulate the session identifier to reference locations outside the intended storage directory, leading to the deletion of arbitrary files and directories on the server. Exploitation requires only a low-privilege authenticated session and a single crafted request. Instances configured to use the Redis-based session store are not affected. This issue is fixed in versions 7.0.3 and 7.1.1.
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 29% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
ZA
zammad · zammad
= 7.0.2; = 7.1.0 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-61525
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-61525
github.com
https://github.com/zammad/zammad/commit/cf3425712e8fae1bd40fa5814a49dc318dc84006
github.com
https://github.com/zammad/zammad/commit/f78ef2434fd8aad6c2fb8a702788f6e3f33565f6
github.com
https://github.com/zammad/zammad/security/advisories/GHSA-xp9w-hhf3-vfxx
More from zammad
9.8
CVE-2026-102489
Undisclosed RCE in Zammad v6.3 and higher
7.8
CVE-2026-102490
Local privilege escalation in Zammad v1.5.0 to v7.2.2 installed via DEB or RPM package
9.8
CVE-2022-48021
A vulnerability in Zammad v5.3.0 allows attackers to execute arbitrary code or escalate privileges via a crafted message sent to the server
9.8
CVE-2022-35490
Zammad 5.2.0 is vulnerable to privilege escalation
9.8
CVE-2021-42090
An issue was discovered in Zammad before 4.1.1
