Medium severity · published Sep 25, 2026
CVE-2026-56735
Zammad: Improper neutralization of `srcset` attribute in IMG tags in Zammad
5.3
CVSS
0.4%
EPSS
No
On KEV
Description
Zammad is a web based open source helpdesk/customer support system. Prior to 7.0.2 and 7.1.0, zammad's HTML sanitizer (HtmlSanitizer::Strict) blocks external URLs in to prevent remote content loading, but the srcset attribute, also allowlisted for , is not subject to the same check. This oversight allows an attacker to embed arbitrary external URLs in the srcset attribute just by sending an e-mail, effectively bypassing the external content protection. When an agent views the ticket containing the malicious srcset, the browser will silently load the attacker-controlled URL, resulting in the leakage of the agent's IP address, User-Agent, Referer, and the exact time the ticket was viewed. HtmlSanitizer::Strict got extended to block external URLs in the srcset attribute of tags. This was done to prevent tracking pixels and external content loading, which could compromise user privacy. This issue is fixed in versions 7.0.2 and 7.1.0.
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 36% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
ZA
zammad · zammad
< 7.0.2 · source: vendor
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2026-56735
CVE.org
https://www.cve.org/CVERecord?id=CVE-2026-56735
github.com
https://github.com/zammad/zammad/commit/02c1ff8dc65961352dc047013bece9dff1f2ffb7
github.com
https://github.com/zammad/zammad/releases/tag/7.0.2
github.com
https://github.com/zammad/zammad/releases/tag/7.1.0
github.com
https://github.com/zammad/zammad/security/advisories/GHSA-7fwx-3xr4-qm6w
More from zammad
9.8
CVE-2026-102489
Undisclosed RCE in Zammad v6.3 and higher
7.8
CVE-2026-102490
Local privilege escalation in Zammad v1.5.0 to v7.2.2 installed via DEB or RPM package
9.8
CVE-2022-48021
A vulnerability in Zammad v5.3.0 allows attackers to execute arbitrary code or escalate privileges via a crafted message sent to the server
9.8
CVE-2022-35490
Zammad 5.2.0 is vulnerable to privilege escalation
9.8
CVE-2021-42090
An issue was discovered in Zammad before 4.1.1
