Medium severity · published Jul 6, 2026
CVE-2026-55514
vLLM denial of service via prompt embeds on M-RoPE models
6.5
CVSS
0.7%
EPSS
No
On KEV
Description
vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.7% · higher than 52% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
VL
vllm · vllm-project
>= 0.12.0, < 0.24.0 · source: vendor, NVD
Affected product
VL
vllm
vllm-project
More from vllm
9.8
CVE-2026-115915
vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE
9.8
CVE-2026-25960
SSRF Protection Bypass in vLLM
9.8
CVE-2026-22778
vLLM leaks a heap address when PIL throws an error
9.8
CVE-2026-22807
vLLM affected by RCE via auto_map dynamic module loading during model initialization
9.8
CVE-2024-9053
vllm-project vllm version 0.6.0 contains a vulnerability in the AsyncEngineRPCServer() RPC server entrypoints