Medium severity · published May 13, 2026
CVE-2026-44581
Next.js: Cross-site scripting in App Router applications using CSP nonces
4.7
CVSS
0.2%
EPSS
No
On KEV
Description
Next.js is a React framework for building full-stack web applications. From 13.4.0 to before 15.5.16 and 16.2.5, App Router applications that rely on CSP nonces can be vulnerable to stored cross-site scripting when deployed behind shared caches. In affected versions, malformed nonce values derived from request headers could be reflected into rendered HTML in an unsafe way, allowing an attacker to poison cached responses and cause script execution for later visitors. This vulnerability is fixed in 15.5.16 and 16.2.5.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
High
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.2% · higher than 13% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
NE
next.js · vercel
>= 13.4.0, < 15.5.16; >= 16.0.0, < 16.2.5 · source: vendor, NVD
Affected product
NE
next.js
vercel
More from next.js
10.0
CVE-2025-55182
Meta React Server Components Remote Code Execution Vulnerability
9.1
CVE-2025-29927
Next.js is a React framework for building full-stack web applications
9.0
CVE-2026-75604
Next.js: Unauthenticated Remote Code Execution on windows-hosted servers
8.6
CVE-2026-44578
Next.js: Server-side request forgery in applications using WebSocket upgrades
8.2
CVE-2026-94482
Next.js: Denial of Service in App Router using Server Actions