Critical severity · published Mar 21, 2025
CVE-2025-29927
Next.js is a React framework for building full-stack web applications
9.1
CVSS
99.2%
EPSS
No
On KEV
Description
Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)99.2% · higher than 100% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
NE
Next.js · Vercel
11.1.4 before 12.3.5; 13.0.0 before 13.5.9; 14.0.0 before 14.2.25; 15.0.0 before 15.2.3 · source: NVD
Affected product
NE
Next.js
Vercel
More from Next.js
10.0
CVE-2025-55182
Meta React Server Components Remote Code Execution Vulnerability
9.0
CVE-2026-75604
Next.js: Unauthenticated Remote Code Execution on windows-hosted servers
8.6
CVE-2026-44578
Next.js: Server-side request forgery in applications using WebSocket upgrades
8.2
CVE-2026-94482
Next.js: Denial of Service in App Router using Server Actions
8.2
CVE-2026-64642
Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale